Community Forum

Add collisions to objects

Forum Overview >> Farming Simulator 2009

CategoryFarming Simulator 2009
Created06.03.2010 13:56


Randy Kool (unknown) 06.03.2010 13:58
I have made a farm with Google Sketch up, and I have placed it in my map. But when I load my map and drive with a tractor on it, I drive straight trew everything. How can I fix this?

Tobias F (JD6930) 08.03.2010 22:03
http://gdn.giants.ch/documentation_exporter.php

-> Attributes Panel

Randy Kool (unknown) 08.03.2010 23:02
I've used Blender to get it to i3d. So your thing is not a option cause that is with Maya

B. Benjamin (unknown) 09.03.2010 23:33
Hello,

You can edit and check the original farm .i3d file and compare it with your own farm. You'll be able to notice the difference between them and add manualy the required attribute ( static="true" compound="true" etc... ).
You can edit your .i3d file with notepad++.

As I'm not using Blender, I don't know if an easier solution exists.

Regards,
Bayn

Stefan Geiger - GIANTS Software 12.03.2010 09:18
You can also edit this attributes directly in the GIANTS Editor.

http://gdn.giants.ch/editor.php#editor_attributes

You should check the rigid body flag, and then the static flag as well as the collision flag.

Randy Kool (unknown) 13.03.2010 11:17
@ Stefan

I did that and now I can drive on a small part of it, also I can stil drive through every shed.

Stefan Geiger - GIANTS Software 16.03.2010 10:40
Have you done this for all parts of your object? Do the objects have scale?

Randy Kool (unknown) 16.03.2010 16:58
I've done this for all parts. Only 1 part has a scale, the others are 1 1 1.

Stefan Geiger - GIANTS Software 17.03.2010 14:13
Could you please make a screenshot of the scene within the GIANTS Editor? Make sure that the physics debug rendering is activated. To do this, right click in the viewport and make sure that there is a checkmark at Show->Physics. Then click the play button in the toolbar.

Randy Kool (unknown) 17.03.2010 15:29
here it is: http://www.plaatjesupload.nl/bekijk/2010/03/17/1268828593-310.jpg

Stefan Geiger - GIANTS Software 24.03.2010 11:22
This looks correct.
Does it look the same inside the map, or do you have a different version if that there, or maybe some scaling?

Randy Kool (unknown) 24.03.2010 16:08
I have placed all things in 1 map, and that map I've scalled to 0.1 0.1 0.1 because it was way too large.

Benjamin G (unknown) 26.03.2010 14:01
the scaling destroy the collision of the object!
you can scal it in Maya/3dsMax and freeze the transformation

Aaron Brueck (ryeguy) 15.02.2017 01:48
thanks



Note: Log in to post. Create a new account here.