Community Forum

Error: Can't add keyframe. Time is not strictly monotonic increasing.

Forum Overview >> Farming Simulator 15

CategoryFarming Simulator 15
Created10.10.2016 21:45


Callum Williams (callum6670) 10.10.2016 21:46
Hello,
I am almost finished making my FS 15 Map, I was about to make a backup so I exit GE and make the backup and store it on my second HDD and I go to open the map again it just keeps crashing.
When I launch the map in the game I keep getting this - http://pastebin.com/iYbPrPir

I have tried opening the map on 4 different versions of Giants Editor and still the same result of crashing

I know about the Error: Render device Error: Unknown. that wasn't causing the issue.

And there is a few shaders what I need to replace but that was fine whilst I was testing it in-game.

Any help or suggestions would be much appreciated, thank you,
Callum.W.

Emil Drefers (giants.edrefers) 11.10.2016 07:18
Hi,

you have a tons of error messages and because of that it is no miracle that the game crashes.

You should get rid of the error messages one after another.

As you said, replace the shaders.
Check the texture file sizes ( ".... width or height doesn't equal 2^n", I hope it's clear what that means.

The following message are caused by an animation:
"Warning: Animation set timeline skipped. Transform group id X not found"
"Error: Can't add keyframe. Time is not strictly monotonic increasing."

A good idea is to start with a map that has no errors at all and check the log.txt on a regular basis to be able to eliminate the rrors as soon as possible.
Otherwise it might be overwhelming to fix "hundreds of bugs" ;)

Cheers,
Emil

Callum Williams (callum6670) 12.10.2016 17:43
Hello Emil,
Thank you for your response back,

The errors was not causing the issue, I was still at 60FPS where ever I am on the map, it was an animation what was causing the issue,

I was not able to open the map in Giants Editor, it was just crashing over and over again so after hours of deleting and restoring files (I know it's long but it's eliminating possible problem causes).

What I did was I deleted the "map01.i3D.anim" file and everything with an animation I had to re-import so it would start that file from new again.

Once again thank you for your response.
Thank you,
Callum.W.


Note: Log in to post. Create a new account here.