Community Forum

Edited DDS causes Giants Editor to crash?

Forum Overview >> Farming Simulator 17

CategoryFarming Simulator 17
Created26.10.2016 18:01


Robert L (Spartan086) 26.10.2016 19:11
Hello GDN,

I've done a lot of map editing in FS15 and editing .dds textures was never a problem.

But now if I extract the Goldcrest map with all the files and textures to a map mod; I can open it just fine at first. But as soon as I open and re-save any of the ground textures such as "maps/textures/terrain/roughGrass_diffuse.dds" it becomes impossible to open the map in the Editor.

As soon as I try to open the map01.i3d file I get "GIANTS Editor 7.0.2 has stopped working". Am I saving the .dds in the wrong format somehow?

I'm saving it as a DXT5 (interpolated alpha), 5 or more mipmaps,.. I don't know what else I could change, it looks just fine when I open it again, mipmaps are there but the Giants Editor seems to freak out completely.

Robert L (Spartan086) 28.10.2016 10:07
The issue seem to be limited to Ground textures (so I can edit crop, building and tree textures just fine). has anyone been able to change the grass/dirt/beachsand textures successfully in any of the 7.0.X versions of the editor on a FS17 map?

Troy Wild (tawsag) 29.10.2016 06:25
What are you using to convert the image to .dds? I had this problem when using DXTBMP, but when I use Paint shop with the DDS plugin, it worked correctly.

Robert L (Spartan086) 29.10.2016 22:32
I got an old Adobe Photoshop CS3 with Nvidias dds plugin.

Dominik Klein (Weedi) 30.10.2016 03:30
I have the same problem.....
I use paint.net


Robert L (Spartan086) 30.10.2016 08:54
Right, I finally got an error message by ignoring the editor crash and loading the map in the game (which also crashed the entire game very early during the loading progress).

Error: Failed to create texture array. Texture 'F:/Steam/steamapps/common/Farming Simulator 17/mods/b_Goldcrest/maps/textures/terrain/roughGrass_diffuse.png' doesn't match the image properties of the other layers.

I've tried downloading the latest Nvidia .dds plugin but that did not help either.

Emil Drefers (Unknown) 01.11.2016 08:46
Hi,

please make sure that the file has the same size as the other terrain texture files.

Cheers,
Emil

Robert L (Spartan086) 02.11.2016 15:01
I am certain it is maitaining its original size (2048x2048 pixels).

One would think a DXT5 is a DXT5, but apparently not. I'm starting to suspect it's just Nvidias .dds plugin that is getting too old. I guess I need to find some more recent software with native .dds and mipmap editing support.


EDIT: Or I'm just wrong again. I think I got it figured now; you just need to find out how many mipmaps each type of texture require.

Distance maps seem to require DXT1 and 9 mipmap levels
Crops want DXT5 and 5 mipmap levels

Can't remeber what the terrain texture and minimap required, but it was something else.

Gerrit Geldenhuys (masepoes) 26.12.2016 18:14
Spartan086. Can you PLeeeeeeease try and remember what the terrain textures required cause thats the main issue with FS17 and you seem to be the only one out there who figured it out.

Marek Ciebiera (PCMASTERR) 26.12.2016 22:47
I have the same mistake.

Malgoku Farmer (malgoku) 10.10.2017 13:50
diffuse dxt5 2048x2048
normal dxt1 2048x2048
distance dxt1 256x256

Bouncy Mc (walster001) 24.10.2017 12:56
Hey, I have discovered when exporting with Paint.NET for those of you who struggle.
When exporting Diffuse Textures
DXT5, 2048x2048, tick the box "Generate MipMaps" and the mipmap type is "Fant"

Kind Regards,


Note: Log in to post. Create a new account here.