Community Forum

Attachable not attaching

Forum Overview >> Farming Simulator 17

CategoryFarming Simulator 17
Created30.10.2016 19:51

Anthon P (Arborfarmer) 30.10.2016 20:05
I thought I'd try to make something for FS17. I decided to just make something simple, something to attach in the three point hitch. I did as I'd done it in FS15 but wrote new xml-files. I used existing models as references for dimensions. The mod shows up in store and everthing just fine, but it won't attach to my tractors. I tried with another i3d-file (one from my FS15 mod) and it worked just fine, so probably the xmls are ok. All the xml-references to the model is correct but still it doesn't attach. Why?

If anyone knows what I am doing wrong and what it really takes to make something attach I would be greatful.

Samuel H. (modelleicher) 31.10.2016 10:02
have you checked the rotation of the attacher joint transform group? It has to be -90 or 90 depending on the direction of attaching

Anthon P (Arborfarmer) 31.10.2016 19:08
Thanks for taking time Samuel. However, this was not the problem. My transform groups were placed and rotated as they are in the ingame Agco 1500 kg weight.

But when I looked through the i3d-file (again) I noticed that the scale of my transform groups weren´t set to 1 ((x y z) = (1 1 1)), so I opened the "Freeze Transformations" and apllied it with the scale-box ticked to set the scaling to 1. And now it´s working just fine! :)

So if anyone else encounters a similar problem, it might just be that the scaling of the transform groups are not set to 1.

Note: Log in to post. Create a new account here.