Community Forum

water fill trigger

Forum Overview >> Farming Simulator 22

CategoryFarming Simulator 22
Created21.03.2022 09:19

David Foster (braveheart) 21.03.2022 09:19
does anyone know how to set up water fill trigger or buy water trigger

Colin Smith (WrinkleysRule) 21.03.2022 11:15
There are a couple of quick ways to find out if your water trigger is in the correct place,
One is to open your map in game and press F5 on your keyboard navigate to the trigger location and if it is correct there will be a box with a yellow outline, triggers show in yellow collisions in red.
Another is to open your map in GE import the placeable directly into the map and set it to the translations that you have in the placeables xml, hen select the trigger itself and 'F' on your keyboard, this will take the GE camera directly to the location of your trigger wherever it may be.

If you have imported the lizard/waterTank/level02 directly from the mapUS and place that where you require the water trigger you should have no problems.
Be aware that the lizard/waterTank/ level01 does not contain a water trigger but is an extension much like the farm silo's ones

David Foster (braveheart) 21.03.2022 13:17
the waterfilltriggers in the placeables folder mapUS under waterfilltriggers won't work its the 2 big water triggers that are for the water towers on the map because i've put in the position and rotation and once i place 1 under the water tower seperate from it of course. when you load mapUS into editor the water towers have no waterfilltrigger with them and i can't find 1 to export from on mapUS because i've tried just importing it from mapUS actual FarmingSimulator game files and its not working so am I doing this all wrong is there something else i need to be putting in the placeables.xml besides this <placeable rotation="0 0 0" position="-0.445 1.084 0.671" filename="data/placeables/mapUS/waterFillTriggers/waterFillTriggers.xml" mapBoundId="waterFillTriggers"/> or do i also need to be putting this in placeables.xml -<placeable xsi:noNamespaceSchemaLocation="../../../../shared/xml/schema/placeable.xsd" xmlns:xsi="" type="buyingStation">


<name>MapUS waterFillTriggers</name>



















<placement useManualYRotation="true" useRandomYRotation="false"/>







-<buyingStation supportsExtension="false" stationName="waterFillTrigger" node="0">

<loadTrigger autoStart="true" fillLitersPerSecond="200" fillTypes="WATER" triggerNode="0"/>

<!-- watertower01 -->

<loadTrigger autoStart="true" fillLitersPerSecond="200" fillTypes="WATER" triggerNode="1"/>

<!-- watertower02 -->

<fillType priceScale="0" name="water"/>


</placeable> because tried that too and when i put that second part i asked about the map won't load in game thanks again Colin

Colin Smith (WrinkleysRule) 21.03.2022 14:32
You are loading the complete mapUS/waterfill Trigger. i3d so your node positions are wrong, they are 3|0 and 4|0 respectively in the ingame i3d.

If you want to use just the WaterTower triggers then create a new i3d with just those in it and ammend your xml accordingly

<buyingStation supportsExtension="false" stationName="waterFillTrigger" node="0">
<!-- watertower01 -->
<loadTrigger autoStart="true" fillLitersPerSecond="200" fillTypes="WATER" triggerNode="0"/>
<!-- watertower02 -->
<loadTrigger autoStart="true" fillLitersPerSecond="200" fillTypes="WATER" triggerNode="1"/>
<fillType priceScale="0" name="water"/>

Node will then be whatever it is in your new i3d probably 0|0 and 0|1 respectively, yours currently refer to the ponds 1 and 2

Also the waterTower triggers are set in the ingame i3d at position="847.886 79.499 973.352" and position="-395.864 79.499 384.602"
respectively so this has to be taken into account when setting placeables location.

Any direct change to the ingame waterFillTrigger.i3d will require a new save under a different name of course and xml set up as above

David Foster (braveheart) 22.03.2022 07:05
how do i know what the node size is where do i see that at

Colin Smith (WrinkleysRule) 22.03.2022 11:32
Node's are not 'sized' they denote the postion (reference) of the object in the i3d.

Open the waterFillTriggers i3d in GE, select any item in the i3d in the Attributes panel you will see some boxes

Name --- Name of the Object
Id ----- Node Id -- this is its reference no in the I3d
IndexPath --- This is the node Index path which is the one the xml uses so for example pond01 index path =0>0 but the trigger index path is 0>0|0 so the xml entry for this would be

loadTrigger autoStart="true" fillLitersPerSecond="200" fillTypes="WATER" triggerNode="0|0"/>

The first 0> is disregarded in this case as ithe trigger is part of one main transform group if there was another separate transform Group it would be 1>

Look at the way the triggers are set in the waterFillTriggers.xml

David Foster (braveheart) 22.03.2022 13:05
I have tried every way that can possible be done with changing xml files making new i3d trust me I've spent hours for the last 2 days trying everything imaginable with the placeables xml file the xml file for the water tank and the water triggers how should it look in placeables xml is it like this (example: <placeable rotation="0 0 0" position="14.291 24.802 -103.915" filename="data/placeables/myWater/waterTankLevel02.xml" mapBoundId="farmWaterTank"/> ) and how should the xml file look for the water tank is it like this ( example:
<filename>data/placeables/myWater/waterTankLevel02.i3d</filename> )
because I've tried every way possible when I copy the xml file from the base game for the water tank and put in the position I have on my map it pops the water tank up in game but I don't want the tank stuff itself I just want the fill trigger and rest of transform group the tank is ugly and just in the way when I'm using the fill trigger for a watertower I've made a new i3d file
with just the stuff I just said I kept put a copy of it in the placeables folder I have and then changed the copy I took of the water tank xml file and changed it to the second example I mentioned nothing works I could use the water tank and just hide it under the water tower but then it puts the load point way to close to the tower and very hard to get at with tractor or water trailer sorry to keep bugging you with this but I have honestly tried every way I possible can maybe I'm not putting in right words or something I don't know so sorry to bug ya again but can ya maybe help you know me I'm a problem magnet lol thanks Colin your the greatest

Colin Smith (WrinkleysRule) 22.03.2022 15:38
I did point out in an earlier post " Be aware that the lizard/waterTank/ level01 does not contain a water trigger but is an extension much like the farm silo's ones"

As I have said previously you will have to creat your own i3d with just the waterTower trigger in it.
First create a folder called myWater in your placeables folder
Open the map/US/waterFillTriggers i3d in GE and delete all the ones not required so leaving just the waterTower one and taking note of the TRIGGER index paths save as "myWaterFillTrigger.i3d" in the folder myWater
Now open the waterFillTriggers.xml and delete all the loadTrigger items except the first waterTower one, and under <filename> put the following
confirm the triggerNode values are the same as the ones you noted previously save this as "myWaterFillTrigger.xml" again in the folder myWater
Now import your myWaterFillTrigger.i3d into your map and adjust the locations either by the main waterFillTriggers transform group or separetly using ctrl 'B', if only placing the waterFillTriggers transform group, note the position and rotation transforms for entry into the placeables.xml. When done , with ONLY the waterFillTriggers transform group selected, select File--Export Selection and save it in the myWater folder (replacing the original)
Now in the placeables xml and modDesc.xml put the following
<placeable filename="$mapdir$/placeables/myWater/myWaterFillTrigger.xml" position="0 0 0" rotation="0 0 0" />
changing the position and rotation values if necessary.
and In the modDesc <storeItems>
<storeItem xmlFilename="placeables/myWater/myWaterFillTrigger.xml" />

David Foster (braveheart) 23.03.2022 01:48
My index path is 13>0 so do I enter 13 or 0 into the watertrigger xml for the node trigger

David Foster (braveheart) 23.03.2022 09:06
and do i need to put map mapBoundId in the placeables xml i figured out the node thing just need to know about the mapBoundId thing

David Foster (braveheart) 23.03.2022 10:05
when I load GE an error: failed to open xml file 'C:/Users/dave foster/downloads/McLeanFarms/placeables/myWater/myWaterFillTrigger.xml' pops up in the console for my map do you think its because theres a space between dave and foster cause i know that that space being there can cause issues with some files and thats the way things are stored on my PC and i don't know how to change it if thats even the problem because i've done everything you said do to the exact and its still not working

David Foster (braveheart) 23.03.2022 10:46
it's also giving me that same error for my sellingStationVehicles.xml as well but my vehice sell station works fine

Colin Smith (WrinkleysRule) 23.03.2022 11:45
Sorry I should have been a bit more precise the placeables.xml entry should have the mapBoundId should the vehicle sell station.

<placeable mapBoundId="sellingStationwater" filename="$mapdir$/placeables/myWater/myWaterFillTrigger.xml" position="0 0 0" rotation="0 0 0" />
changing the position and rotation values if necessary
Double check your file paths both in the modDesc store items and placeables

Just a quick word about the index path problem, probably caused by using the index path when imported in the map , it should be checked by opening your new saved myWaterFillTrigger.i3d in the placeable folder

David Foster (braveheart) 23.03.2022 13:59
Colin i really appreciate your help but i've followed everything you've said to do i got the editor to stop with the error of not reading the xml files i've changed the placeables.xml file exactly the way you showed and i changed the node to exactly what it shows in the editor in the myWaterFillTrigger.xml i've added exactly what you've showed to the modDesc.xml i've tried everything possible and its still not working i have seriously wasted over 30 hrs of my life trying my hardest to figure this out this has stumped me more than any problem i've had crotchfrog even came to my discord and explained another way and it didn't work either its really not needed because theres so many types of watertanks in the game that people are just gonna put water closer to where they want it anyway it would have just been nice to give the water tower some real function oh well i guess because i'm at a loss seriously don't have no clue on what to do to get this to work anyway thanks again Colin your awesome you and crotchfrog both thanks again and any last advice on things to maybe check or look for or change because i'm going to give it 1 last shot tomorrow for a bit and if i can't get it to work just move on i got some decoration stuff to finish up thanks

Ed Propsner (crotchfrog) 23.03.2022 16:05
Out of curiosity, add this same line <storeItem xmlFilename="placeables/myWater/myWaterFillTrigger.xml" /> to storeItems.xml instead of modDesc and see what you get. Either should work just fine but I'm confirming/debunking a suspicion so humor me :)

David Foster (braveheart) 24.03.2022 00:24
that didn't work either

David Foster (braveheart) 24.03.2022 02:52
Is there anyway I can make the watertank02 work without the tank it's self because I tried making one without the tank and went thru the whole process of fixing the xml's like you said for water trigger but with everything for the myWaterTank.i3d I made then loaded game and it showed a place to get water on my map but no load trigger and its doesn't work at all can't fill anything with water when I press F5 it shows the fill trigger on the ground but nothing works thinking maybe if I try using it instead of water triggers since I can't seem to get it working oh and when I went thru the process of doing the water tank that I made without the tank I loaded game once and I could see the load trigger in the air but my position and everything was right in xml for it to be on ground where it was suppose to be so if I can figure out this reason maybe I can get it to work for me instead. Thanks guys sorry to keep bugging with this.

David Foster (braveheart) 24.03.2022 06:12
After tremendous amount of help from you guys and learning so much from all this about xml altering and loads of cussing and frustration from myself I finally got the water tank to work perfect where it looks like its just an ordinary trigger to get water from the water tower like it's meant to be thanks again Colin I've learned a lot from all this that I'm definitely going to use on my next project that will help me create my next map Ed thank you again as well for so much advice a long the way all I have to do left is to finish some decoration things and set up my farmlands now I know what I want to section off into each farmland thanks again and look for my map on modhub soon it's call Hardin TX. ( McLean Farms.) be so called to finally be able to stream it and fully play on it as well check me out on twitch soon Crusty_Farmer is my channel man Thank You guys so so much I appreciate everything stay safe and God Bless

Ed Propsner (crotchfrog) 24.03.2022 12:26
Glad you got it working, I knew you would!!

Note: Log in to post. Create a new account here.