Community Forum

Land and Field Ownership - Edit

Forum Overview >> Editor

Created01.03.2022 17:02

Kendall Demott (HC1Gunner) 01.03.2022 17:02
GE 9.0
Back when 22 1st released, I was doing an edit on Elmcreek, since there is very little room for placeables, I deleted some of the eye-candy buildings. I got rid of the car dealer one near the Store, and a couple of other places on the map.
Just like I have done a ton of times for 17 and 19, select the blue icon (terrain info layer paint mode). I had my cursor over the small farm of #44 - #46, hit Ctrl+R, the area goes White, I then went to the area where the Store is, and painted the area white, but when I got into my saved game, I could not place any buildings.
After posting to the forums, with some suggestions, I created a new saved game and it worked, then when I went back to my old save, I now had ownership of the Store area. Currently I have productions buildings on areas where I deleted some builds, and they are all work fine, and I can still add more placeables to these areas.

GE 9.0.2
Well now they have messed something up again, I can’t take ownership of any land or unused non-field area via GE.
I tried do this (2) ways...
1. I owned both fields 42 and 50, I added the area where I removed the building that was adjacent to 42, and then made it part of field 42. This did not work in-game, no ownership for the non-field area, the area was not added to # 42.
2. then I also went to small farm area (I own), area is showing white (Ctrl+R), moved to the area between 42 and 55 and painted white, saved. This did not work, no ownership for the non-field area.

I can’t find a way in GE to take ownership of any field, or non-field area. I don't know if they changed the commands in GE, added a new tool that has to be used, but it looks like to be the same method is still used that worked for 17 and 19.
I tried using this a couple of mods that allow you to place buildings anywhere, but then the production would not function because the game stated I didn’t own the land under them.
Help Please !

Ed Propsner (crotchfrog) 02.03.2022 17:19
Sounds like a save game issue with the infolayers. I assume you tried the same you did last time and start a new save game then go back to your original (I'm not quite sure how that would work, but you can't argue with results)? I have little doubt that you will own the land in the new save. There are no new methods or tools for this in GE 9.02

Edit: Just an afterthought, in the map.xml there is a section that you can add/change revision numbers. So, for example, if you change the tip collision map you can update the revision number and it will force a save-game to reload the collision map (or whichever you choose) without having to manually delete it, which coincidentally may also work in your case (always keep a backup).

Kendall Demott (HC1Gunner) 06.03.2022 01:06
Creating a new save game does not work, still don't have ownership.
If I make an open area adjacent to a field (add the area to the field), when you are in-game, and try to purchase said field, the area added is not showing blue, so it can't be purchased as part of the that field.

Ed Propsner (crotchfrog) 06.03.2022 04:06
If you are adding, subtracting, or merging fields/farmlands, the farmlands.xml needs to be updated as well. Make sure that xml reflects the changes you are making to the infolayer. The error log should tell you if something is not right with it.

Note: Log in to post. Create a new account here.