Community Forum

Corrupt file

Forum Overview >> Editor

Created08.03.2022 22:24

Ed Propsner (crotchfrog) 08.03.2022 22:24
@Colin or Bilbo: What do you guys make of this ...

I left one of my maps open in GE while I ran a quick errand. When I returned the map and editor were both closed. Maybe I did close it? I got an error when I tried to open saying it couldn't be read. I tracked the error down to one particular line and oddly enough it's all gibberish, almost like you would see when viewing a photo with a text editor. Almost, but not quite. It seemed like it was taking a bit to load which shouldn't be an issue for a text file and the amount of RAM I have. I checked the file size and it's over 500MB! What in the world? Even if GE crashed while I was gone, how in the world would I end up with a 500MB data dump in the middle of the file. The entire project, placeholders included, is not even that big.

Colin Smith (WrinkleysRule) 08.03.2022 22:42
Did you save anything before hand like a placeable, I've had that happen when I saved a map by using the save i3d icon with an object in the scenograph still selected

Ed Propsner (crotchfrog) 08.03.2022 23:05
The map was complete, I was just doing touch up work like tweaking street signs. It's completely possible that I had something selected when I saved, but nothing that big. It's bigger than the entire project! What I think is a possibility is that I usually have the i3d open in ++ with a handful of other files, and I might have been moving something else around one of the folders maybe and pasted into the i3d without ever realizing. The entire 500MB dump is on a single line right in the middle, wherever the cursor would have been most likely. I don't recall doing this but it's very possible since I'm usually pretty active in the folders moving things around.

Now I need to get it out of there. The file is so large I can't work with it. I'm toying with editors designed for larger files as we speak but the current one is giving me grief because it's a different character set.

Colin Smith (WrinkleysRule) 09.03.2022 11:47
If you have an item in the scenegraph selected when you use the save i3d icon it will save the complete map including your original shape and terrain lod files to the selected item which then has all that information plus a new complete map in its shape file plus new terrain lod stuff so in effect doubling the size of your folder.

The only way around this I think , and I haven't tried this myself is to rename the new shape file to the original map one and replace the old terrain lod etc with the new ones and in the i3d comment out the rogue section then try opening the map as normal.

Ed Propsner (crotchfrog) 09.03.2022 13:52
I'm very adamant about backing up at least the i3d, but for whatever lazy reason, I did not this time, but we won't talk about that. What I will say however, and this is the second this has happened to me, if you ever have something like this happen and you leave a break in the script itself, like a literal gap with an open line, not so much an open tag but more like complete termination mid-sentence, and you try to save the file as an i3d, you run a high risk of losing everything below the break. I'm not positive of the exact conditions, but it does have to do with a break in the script. The really bad part about this is that if you do not have a backup, you literally just overwrote the only existing copy of your i3d by performing the save. I successfully removed the offending data dump but had no clue there was another break elsewhere in the script. So whereas the map was ready for upload yesterday, I'm now pushed back to maybe next month. I'm not sure what magnitude of a catastrophe it's going to take for me to learn a lesson, but apparently this isn't it.

There were a lot of should haves and could haves (amongst some other choice words) floating around this house yesterday. I astound even myself sometimes with the poor choices I make in the face of knowing better.

Back your stuff up people!

Colin Smith (WrinkleysRule) 09.03.2022 17:19
It would be nice if when selecting "Save As" to have the -+ prompt to advance/retard numerically, as in Blender when saving a file.

To be on the safe side always use the "Save As" option when saving a map, even if only doing small edits, in fact move that save /reload icon section to the other end of the tool bar (by hovering the mouse over the dots and dragging) that way you will get used to using File --Save As instead of the icons

Ed Propsner (crotchfrog) 09.03.2022 21:12
I like this idea!!

Note: Log in to post. Create a new account here.