Community Forum

Can't use Editor (Error "Can not creat OpenGL View")

Forum Overview >> Editor

Created02.11.2016 02:56

Andreas Dalaker (Unknown) 02.11.2016 02:57
Hey, Just installed the editor, when i try to open i get the error message can not create OpenGL View.

Can someone help me get thru this problem?

Robert L (Spartan086) 02.11.2016 15:06
What graphic card do you have? It probably does not support the OpenGL version that the Editor is using.

Trevor Ritter (duramaxman78) 09.11.2016 01:42
will this graphics card support GE NVIDIA GeForce 940MX graphics card with 2GB of DDR3

Tarja Valic (Unknown) 09.11.2016 13:30
Trevor you graphics card is very weak,940MX is the laptop GPU,with 64bit main pipeline i doubt about that.
You can probably open the editor,but editing the map will not be best experience,Giants editor 7 needs strong desktop GPU and 4 cores CPU to work smooth,and your card is the greenline series made for energy save not for hard graphics tasks.
I suggest you should try on LOW profile.

Trevor Ritter (duramaxman78) 09.11.2016 19:07
I can open the editor I just get a grey screen with profile on low profile what's a cheap graphics card upgrade too for my laptop to be able to use GE

Trevor Ritter (duramaxman78) 09.11.2016 19:07
I can open the editor I just get a grey screen with profile on low profile what's a cheap graphics card upgrade too for my laptop to be able to use GE

Tarja Valic (Unknown) 09.11.2016 20:07
Well,i cant answer on that question,you must first tell me what sort of laptop you have,which brand and model,im deal with this every day,cause im electronic engineer,this is my job,so i can tell you what are you options after you give me information about your laptop.
If you have budget laptop then you are left with no options,GPU procesors on cheap,and even in the middle range laptops are part of motherboard,so you cant remove it or change it.If you have expensive laptop like maybe DELL XPS range,or Alienware(LOL),then you can change you GPU,but im doubt about that,cause this models doesnt have cheap GPU like yours.
Anyway give me the brand and model,and maybe i can send you in right direction Trevor.

Trevor Ritter (duramaxman78) 09.11.2016 20:55
just n old acer aspire 5750 model number P5WE0 so I proably cant change it intel core i3

Troy Christensen (hunter1390) 09.11.2016 21:04
Just outta curiosity I have an Asus w/ i7 and nividia gforce gtx 960m card but I can't run any version of giants editor

James Norred (Cajunwolf) 10.11.2016 02:43
It might be the cards shader version, are you playing the game (which one) on either computer, or console? It does sound like a video card, or at least a driver issue, but if it works in game, it should work in the editor. You've asked this twice, and I gave you an answer in that thread, you need to keep the same topic to the same thread, it confuses when you don't. Something doesn't add up because the editor should run fine on the same machine you play the game on, even if you have to set your profiles to low.

James Norred (Cajunwolf) 10.11.2016 11:10
Troy, check your other thread, I answered in it.

Tarja Valic (Unknown) 10.11.2016 15:07
Your laptop Trevor is not gaming laptop,this is just mainstream business machine,made for Microsoft office and similar,it is not design for gaming,sorry,you must buy another computer.Desktop machines are far better,then laptops,exept Alienware MX series,but few people have money for this,and for same money you can get even more powerfull desktop beast.
Troy you have pretty decent machine,and you shouldn´t have any problem running the editor,with the hardware side,with software probably are problems with drivers you know,this card is year or two old,so problems with shaders are out totally.GTX 960 have hardware and software support for newest shaders.
Drivers are main reason for crashing with giants editor,cause mobile chips are little different then desktop versions.
Before few years,a had a Dell laptop with pretty powerfull graphic card,and in that time,Bioshock go out,i remember every time i try to run this game,drivers are instantly going crazy,and in the final crashing and go in automatic recovery,so i bet this is in your case main suspect Troy.
You should try update the drivers for your GPU,maybe you can find new version.
Good luck!

João De Paula (Unknown) 28.01.2017 13:29

João De Paula (Unknown) 28.01.2017 13:31

Bilbo Beutlin (BBeutlin) 28.01.2017 17:39
Is your keyboard broken? you capslock key jammed?

And what do you expect without giving some more information?
Which OS? how much RAM? which gfx card?
What does the "editor_log.txt" say?
Did you install the GE properly with rightclick -> as administrator?

Jordan Reando (Unknown) 10.03.2017 19:09
When I open GE i get the same error message "can not create OpenGL Viewport". If my how do i get a new graphics card and which one is the bes to get that will support the newest GE? Is there any other version of GE i can use untill i get a new Graphics card? Your help would be very much appreciated. I am using a newer Dell desktop computer.

Thomas Wyers Jackson (Unknown) 23.04.2017 03:59
It won't let me open any of the editors, but I updated my graphics card which is an Intel graphics card and a Asus U56E.

Kyle Newman (Unknown) 29.04.2017 04:28
I am also having a problem with opening GE. My components are satisfactory to run the editor, but it is still flagging me with the error openGL viewport.

Thomas Wyers Jackson (Unknown) 02.05.2017 22:05
I've only had luck with GIANTS Editor V.6, But not any of the V.7 Editors and it is still saying "Can Not Create OpenGL Viewport".

Thomas Bos (Unknown) 24.03.2018 15:35
i have the same problem.
i can open GE from 2013 but not the one from 2017 :C

Tristan Trumaine (Tristan666) 19.08.2020 22:33
I'm getting a 2060 super with 16gb of 3200mhz and a ryzen 5 3600x(3.8) mhz with Windows ten do you reckon I will be able to run giants map editor on fs19

daswieselvomjura 19.10.2020 17:34
I have a Dell Latitude E6320 with windows 10 Home x64 8192MB RAM and i5-2540M. The Graphics Card is Intel HD Graphics 3000. When I run Giants Editor 7.1.0, I get the error: could not create Opengl viewport BUT Farming Simulator 17 runs perfectly well. Why is Farming Simulator working, but Giants Editor isn't?

Bilbo Beutlin (BBeutlin) 19.10.2020 18:00
The Intel HD 3000 does support OpenGL only upto vs. 3.1 (Linux 3.3).
The GE 7.x requires at least OpenGL 3.5 support (GE 8.x OpenGL 4.5).

The FS game runs also with DirectX instead OpenGL.

Note: Log in to post. Create a new account here.