Community Forum

Error while saving I3D file

Forum Overview >> Editor

Created20.06.2009 18:06

Majolka Žolka (Unknown) 20.06.2009 18:08
I recive message any time I want to save my i3D file. (maps, models...) I am running Windows Vista x64. Why is this happening? Please, I need help over there!

Christian Ammann - GIANTS Software 21.06.2009 15:08
Please post your GIANTS Editor log here.

Majolka Žolka (Unknown) 21.06.2009 22:19
I am using GIANTS_Editor_4.1.2
I get message: IMAGE:
Or what do you mean?

Majolka Žolka (Unknown) 21.06.2009 22:20
Or you mean Log File Path. It is located over here: C:/Users/Žagar/AppData/Local/GIANTS Editor 4.1.2/editor_log.txt

Stefan Geiger - GIANTS Software 22.06.2009 11:23
If believe the problem is, that you are trying to save to a folder were you have no access rights to.

So start the editor as admin, or temporarily save to a different location (eg on the desktop) and then move it to the folder you want it to.

Majolka Žolka (Unknown) 22.06.2009 13:24
I already tried this. But still no luck. Is there any other possible problem with my GE?

Majolka Žolka (Unknown) 22.06.2009 16:14
In now try to remake tractor, I do couple of thinks on it, and save it to folder "maps". It works! I can save thinks in "maps" folder, but if I do this, my new tractor model will be without any colors, only white colored. It seems thet textures are missing because it is not saved in its right folder. What can I do, that I will be able to save my mod anywhere else, not just in "maps" folder?

Honza Sebestu (Unknown) 08.07.2009 16:19
I've got same problem. At saving Error while saving I3D file , editor_log.txt I'm nowhere in my PC do not find

Honza Sebestu (Unknown) 08.07.2009 16:27
If open ..I3D in ZIP files, save is going, only without textures, only white, if open .I3D unpacked, save doesn't go

Christian Ammann - GIANTS Software 08.07.2009 18:15
You should not open i3d files from ZIP files within the editor.

Where do you try to save the i3d file on you harddrive? Do you have access rights there? Is it on an UNC path ?


Honza Sebestu (Unknown) 09.07.2009 08:54
I was trying it save in H:/ there it doesn't go to the C:/ yes . Access may I have everywhere. I don't know what's UNC path ?

Christian Ammann - GIANTS Software 09.07.2009 10:46
Is H:/ a mapped network drive on your computer?

Honza Sebestu (Unknown) 10.07.2009 13:26
H:/ is local drive in my PC

Majolka Žolka (Unknown) 17.07.2009 11:18
I was trying to save my i3D file everywhere in my disk. I am possible to save my file only in "maps" folder. Then, when I want to drag file from "maps" folder and drop it in my mod`s folder, when I open my i3D file with GE or In-game it is whit texture. So Is there the problem with my Windows Vista 64bit or with Giants Editor ?

Christian Ammann - GIANTS Software 19.07.2009 09:13
Hi Majolka,

If you drag i3d files you have to copy the texture files as well because the path to the textures are stored in the i3d and if you drag i3ds around that path changes.


Majolka Žolka (Unknown) 19.07.2009 13:58
I now know solution that works. All I have to do is that i have to place whole mod folder in folder "maps" and then I could edit i3D file with all the textures.

Richard Van De Ruit (Unknown) 23.02.2011 10:20
I have bought the SDK version and I import my map from the data file everything seems ok. When i want to edit the terrain etc. I cant see the "terrain editing" window and after doing all the changes i can't save the i3D file overiding the origional. I to have tried saving it in another folder but when you open the game none of the changes have taken effect.
I would hate to think I have wasted $'s for nothing. I am running Windows 7 64x anyone out there to help me?

Jon Bailey (Unknown) 28.03.2011 18:50
i too am running windows7 and i cannot save my modded maps,i get the error while saving i3d file message and i have tried all the options and ideas from these forums to no avail.never had any bother with 2009 only with is a much better game except for this problem

Note: Log in to post. Create a new account here.