Community Forum

GIANTS Editor 7.0.5 64-bit has stopped working

Forum Overview >> Editor

Created20.03.2017 14:37

Don Smith (Baalgauge) 20.03.2017 14:41
Was working on a map no problema few days ago, finsih what i was save and exit , few hours later tried to start up GE again and it wont start , no matter what i try to do. i restarted pc, uninstalled GE with Revo Uninstaller Pro. still say exact same thing as before

GE log
GIANTS Engine Runtime 7.0.0 (13783) 64bit (Build Date: Nov 21 2016)
Copyright (c) 2008-2016, GIANTS Software GmbH (, All Rights Reserved.
Copyright (c) 2003-2016, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 7.0.5
Main System
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
Memory: 4095 MB
OS: Windows NT 10.0 64-bit
Physics System
Version: 5.9.5
Thread(s): 1
Sound System
Driver: OpenAL Software
Render System
Driver: OpenGL
Card Vendor: NVIDIA Corporation
Renderer: GeForce GTX 650 Ti/PCIe/SSE2
Version: 4.5.0 NVIDIA 378.78
Shader Version: 4.50 NVIDIA
Max. Texture Layers: 16
GL_AMD_depth_clamp_separate not supported
Check for updates (

screenshot of the error

Tony Price (brownthumb) 26.03.2017 17:08
Hi Don, i'm old and slow and don't know a lot about computer's and such, but i did think to match your log to mine and it seems that the parts left between your last 2 log entries has a lot to do with graphics, would seem you might need to update a driver or 2 if you are using windows os, was thinking windows came out with a good size update about the time of your demise, it could have messed with your drivers.

Rob Van Den Berg (thudge) 26.03.2017 22:22
Hi Don, I don't think the cause of the problem is listed above. This problem is specific for just that one map, correct ?

Brad Robinson (Rbk_3) 04.05.2017 01:42
I have the same problem. I have an i7 6700k 1080 GTX PC and I updated to 7.1.0 and maps keep freezing . I tried deleting a reinstalling and used CCleaner to get rid of the old Registers but it won't work. I even created a new Windows account and installed GE on a completely separate windows account but the same thing happens. I tried going back to 7.0.5 and still the same problem.. I just cannot figure it out.

The same maps open fine on my crappy laptop.

Nick Uytdewilligen (NickJay) 16.06.2017 16:57
I got also the same problem i7 7700k and gtx 1080ti does crash but on my Acer Aspire R13 it works with no problem and it does crash on every single map i try

Rutger Blom (Unknown) 28.06.2017 14:03
Hi, I'm not an exper on this, but if the GE crashes right after startup. Try opening the i3d and shapes file at the same time, it works for me.

Note: Log in to post. Create a new account here.