Community Forum

Tedder workArea / turning grass to hay

Forum Overview >> Editor

CategoryEditor
Created23.07.2017 18:33


Matthias F. (MBP219) 23.07.2017 18:33
Hi,

I'am building my own map and while testing it I noticed that tedders (and rakes) don't work properly. When driving over mowed grass not all the grass heaps become hay heaps so that there are grass spots within all the hay.
So my question is: Is it more likely a problem concering the workArea of the tedders (I have used the normal ingame tedders and no mods) or could there be a problem with the map?
In contrast to the standard maps my map is a bit more hilly but also smooth so that the tedder always contacts the ground.
Moreover, there is no such problem with mowers, balers, forage waggons or harvesters.

I would appreciate if someone could help.
Thanks.

Emil Drefers (Unknown) 24.07.2017 08:05
Hi,

hmmm, well you should have similar problems with mowers at the same spots, I'ld say.
At least if it is the following prooblem: the "tipAny layer"
For the tipAnything feature (tip to ground) there is a layer which prevents the user from tipping at certain spots.
Did you modify this layer? If not it might be the reason for your problems ;)

Cheers,
Emil

Matthias F. (MBP219) 24.07.2017 21:24
Hi Emil,

thanks for your answer and your hint :-)
Of course I've checked the tipCol layer. It's not the problem. There are no white squares at all defining the area where you can't tip anything. I've also deleted the tipColInfoLayer.grle to force giants editor to generate a new one when saving the i3d.
As I've mentioned mowing the grass works without any problems. While searching the internet to find a solution for the problem I found some forum threads where people were discussing about the mowing bug caused by the tipCol layer and I figured out that this definitely can't be the reason for my problem.
In my previous post I didn't mention the fact that the problem occurs depending on the drive direction: When driving in north or east direction the tedders and windrowers work correctly. But while driving in opposite direction (south or west) the problem comes up again and the tedders/windrowers leave out some of the mowed grass.

I hope this describes my problem more precisely.


Emil Drefers (Unknown) 25.07.2017 06:52
Hi,

that sounds really strange.
Do you use a lot of mods? (It's always worth to try it again without any mods)

Well, I don't think that I can reproduce the problem here.
So, can you make your map available to us?
Maybe you could upload it somewhere?
Eventually you could upload it to the ModHub and add a note/explanation to it (with reference to this thread)

Cheers,
Emil

Matthias F. (MBP219) 25.07.2017 21:17
Hi Emil,

I tried it without any mods, too but the problem stays the same. To reproduce the problem you can download Sheldon's S├╝dharz 1.2 for example: https://www.modhoster.de/mods/sudharz-map--4
The problem occurs also when using his map and it's exactly the same behaviour. Moreover, I read a comment from Lukas=) who has the same problem with the Flusstal XXL Map -> https://www.modhoster.de/mods/im-flusstal-xxl

I think it's a problem related to 4x maps in general, because my map and the both mentioned above are 4x maps and I can't reproduce the behaviour with a normal sized map.

p.s. I hope you unterstand that I don't want to upload my map at the moment because I think it's not ready yet. I planned to upload it at a later point in time when the main work is done.

Emil Drefers (Unknown) 26.07.2017 07:03
Hi,

yesterday I had a look at the map "de terra italica".
That map has the same or at least a similar problem.
Replacing the file "terrainDetailHeight_density.gdm" with the one from the base game resolved the problem.

So, try that :)
If it helps we can have a look and see how we can resize it or rather create a new one with the right size for a 4x map.

Cheers,
Emil

Matthias F. (MBP219) 26.07.2017 19:50
Hi Emil,

I tried the "terrainDetailHeight_density.gdm" from the base game, but it didn't solved the problem. Its size is 4096x4096 pixels (as well as the gdm file from my map).
But scaling the "terrainDetailHeight_density.gdm" to 8192x8192 pixels was what had to be done :-)

So if anyone else has the same problem: I solved it by following these steps:
- download the grle converter from the GDN download section
- drag your "terrainDetailHeight_density.gdm" file from inside your map's map01 folder onto the converter.cmd script (grle converter) to generate a
"terrainDetailHeight_density.png" file
- remove the "terrainDetailHeight_density.gdm" from the map01 folder
- make sure to keep the "terrainDetailHeight_density.png" file inside the map01 folder
- open your map01.i3d with the giants editor
- save the map to generate a new "terrainDetailHeight_density.gdm" file
- remove the "terrainDetailHeight_density.png" file from the map01 folder
- start a new game to test if it works

@Emil: Thanks again for your help. Your last post finally let me solve the problem :-)


Kind regards,
Matthias


Note: Log in to post. Create a new account here.