Community Forum

vehicle camera issues since 1.2 update

Forum Overview >> Editor

Created12.12.2018 18:15

Brian Smith (bs98765432123) 12.12.2018 18:15
every thing is fine in the in game maps, the problem happens in a converted map i am working on. Cab view works for the lizard pick up trucks but as i drive in external view around that camera freezes, switch to cab and everything is fine. As for any tractor i cant get cab view or external view, the view is frozen standing next to the tractor. I can see the mph go up and hear the engine accelerate but nothing moves. Anyone else having similar issues? any ideas where to start trying to figure this on out? eveything was ok until steam gave me the new patch this morning :(

William Svederberg (williamsvederberg) 12.12.2018 18:44
I have the same problem! It occurs when the exhaust particle system enters the viewport.

Brian Smith (bs98765432123) 12.12.2018 19:07
seems to be a converted map problem, i loaded up westbridge hills, same issue.... hopefully we dont have to wait too long for the next patch, let me know if you solve the problem before then

Sezon Dev (Unknown) 12.12.2018 21:00
Same problem for me

Sezon Dev (Unknown) 12.12.2018 21:00

Luke Lee (Luke974) 12.12.2018 23:13
Same problem for me to. I have 2 converted maps and only 1 of them has this problem. There is nothing in the log ingame or in the editor console.

Sezon Dev (Unknown) 12.12.2018 23:56
You could compare your two maps to see if something was changing between them?

Brian Smith (bs98765432123) 13.12.2018 02:43
Fixed it!!!! saw some forum posts and turns out of all things its a water plane issue. I will quote the forum info

. "What I did was exported the waterplane from Ravenport - the beach one to be exact.. put it underneath my mod map and duplicated it, flipped the duplicate 180 degrees... and boom problem fixed. GREAT catch on that one I dunno how you did it lol and thanks for posting."

i did exactly what they did and it worked, not sure if you need a duplicate flipped, it could just be what the next quote says

"So with the sea plane selected, that you wish to add the main attribute to, open User attributes window if not already open.
Now add this in the name “onCreate” and add this into the type “scriptCallback” and add
Now add this in the name “isMainWater” and add this into the type “boolean” and add.
Now type in the onCreate “Environment.onCreateWater” and then make sure to tick isMainWater"

i'm kind of too burnt out now to further test, but at least i can drive around the map again, hope this info helps, its a starting point, farm sim is a love hate relationship and modding sometimes is walking around in the dark with a crappy flashlight. best of luck

David Brown (mrscsi) 13.12.2018 06:17
Thank you I was ALMOST to this conclusion LOL I was taking things one by one out of a mod ravenport map until I broke it But at least it is not a "BUG" just a freakin UNDOCUMENTED FEATURE

David Brown (mrscsi) 13.12.2018 06:18

Luke Lee (Luke974) 13.12.2018 07:58
Water plane, explains it i guess one of my maps has one the other doesn't. Wouldn't have put it down to that though, but thank you posting the fix.

Note: Log in to post. Create a new account here.