Community Forum

GE is running but Viewport is not working

Forum Overview >> Editor

Created19.04.2020 21:16

Michael Warnke (MikeFarmer) 19.04.2020 21:16
Hello together,

this is my first thread in the GDN-Forum and I desperately hope that I can get some help here. My problem is that the editor seems to be running quite alright but the viewport behaves really strange. When I start the GE the Viewport is completely empty. There is no grid and no gizmo. When I scale the other windows like attributes or scenegraph, they leave some sort of shadow in the viewport. When I open a mod the parts are shown in the scenegraph but the viewport remains empty. I have deleted the GE several times including the files in the AppData folder and installed it all new. I have even made a full reset of my computer. But in the end the result was the same. And it is the same problem with versions 8.1, 8.2 and even the last version of GE 7. The GE worked perfectly until last monday. After opening an closing with a new mod the problems appeared. This all seems like a big mystey to me. Maybe somebody here can help me. I would be very, very grateful.

Here is the editor log.

GIANTS Engine Runtime 8.0.0 (18339) 64bit (Build Date: Feb 9 2019)
Copyright (c) 2008-2019, GIANTS Software GmbH (, All Rights Reserved.
Copyright (c) 2003-2019, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 8.1.0
Main System
CPU: Intel(R) Core(TM) i5-7300HQ CPU @ 2.50GHz
Memory: 8060 MB
OS: Windows NT 10.0 64-bit
Physics System
Version: 5.9.5
Thread(s): 2
Audio System
Driver: SoftMixer WASAPI Stereo
Version: 2018.11
Frequency: 48000
Max. active sources: 256
Render System
Driver: OpenGL
Card Vendor: NVIDIA Corporation
Renderer: GeForce GTX 1050/PCIe/SSE2
Version: 4.5.0 NVIDIA 441.41
Shader Version: 4.50 NVIDIA
Max. Texture Layers: 16
GL_AMD_depth_clamp_separate not supported
Started 2 threads for threadpool 'Render threadpool'
Hardware Profile
Level: High (auto)
View Distance Factor: 1.100000
Shadow Quality: 1.000000 Base-Size: 2048 Filter-Size: 16 Shadow Focus Box false
Shader Quality: 2
Skip Mipmaps: 0
LOD Distance Factor: 1.100000
Terrain LOD Distance Factor: 1.500000
Terrain Normal Mapping: Yes
Foliage View Distance Factor: 1.400000
Volume Mesh Tessellation Factor: 0.850000
Tyre Tracks Segments Factor: 2.000000
Max. Number of Shadow Lights: 3
Max. Number of Lights: 512
Max. Number of Lights Per Cluster: 32
Bloom Quality: 4
SSAO Quality: 12
DOF: Enabled
Cloud Quality: 3
Check for updates (

Bilbo Beutlin (BBeutlin) 20.04.2020 05:23
You say "GE worked perfectly until last monday". Then I'd assume a Windows update has confused your system.
Check all important system and gfx settings. These are often resetted by an update.
Espec. inspect the settings of OneDrive. Don't use cloud storage for GE related files, all should be on local drives.

Michael Warnke (MikeFarmer) 20.04.2020 16:23
Thanks for your reply.

All mods I worked on are stored on a local drive. I do not use OneDrive or any kind of cloud storage. But my mods do not seem to be the problem at all as the problem with the viewport also appears without any mod or map opened. I think that it is a more general problem between my computer and the GE. But the strange thing is that the problem occured during one session. At the beginning I opened one mod with the GE for only a few minutes and closed it without saving. The computer remained activated without any kind of updating or installing (as far as I know ;-)) and then, only a few hours later I tried to open another mod when the viewport stopped working.
Unfortunately my computer skills are not very good so I do not really know what kind of settings you might mean and where I could find them. I have checked the drivers for my graphics and CPU. They all have the latest versions. Also OpenGL and DirectX are up to date. I think this is very curious and I have simpy no idea what might cause the problem as the graphics seem to work fine with any other application or game.

Bilbo Beutlin (BBeutlin) 20.04.2020 18:25
Such things can happen at major changes of gfx settings. This appears often unknown at a Windows update. But eg. also if you change screen resolution or monitor type.

However usually this gets 'repaired' if you delete the file "{USER}\AppData\Local\GIANTS Editor ...\editor.xml" and the content of the folder "shader_cache".

Michael Warnke (MikeFarmer) 20.04.2020 19:12
Unfortunately deleting editor.xml and the "shader_cache" content has no effect. The problem remains.the same.

Bilbo Beutlin (BBeutlin) 20.04.2020 19:22
I've just seen your screenshot in general forum.
Looks like a problem with gfx driver. Not always is the newest driver the best. I've read from compatibility problems at new Nvidia drivers as well as AMD.

Try out:
Go to Nvidia control panel, 3D global settings and disable the shadercache. You will barely need it, the GE has its own shadercache as well as most actual 3D programs/games.

Also useful is "triple buffer ON" , "vert. sync FAST".

Beneath: DO NOT USE gfx utilities like Nvidia Experience. Such dumb programs do more damage as they are useful.

And clean up your system. Ban all this Xbox crap and other stuff which might access the gfx card directly.

Michael Warnke (MikeFarmer) 20.04.2020 21:17
Sadly once more no positive effect. Maybe I should try to find somekind of witch or wizard to get this nasty little demon out of my pc. ;-)

Bilbo Beutlin (BBeutlin) 20.04.2020 21:53
Yes, quite difficult to find the failure since it has not a typical pattern.
If you have a friend with enhanced PC experience, let him have a look onto your PC.

A vague speculation: it might be caused by a conflict between your iGPU (CPU internal HD 630) and your eGPU (GTX 1050). Maybe for some strange reason the HD630 isn't disabled completely if the eGPU is active. IIRC just recently the Intel gfx drivers got an update. Perhaps not the best. *g*
You could check this by disabling the iGPU in BIOS (temporarily for test).

Note: Log in to post. Create a new account here.