Community Forum

GE 9.0.2 Crashes

Forum Overview >> Editor

Created25.12.2021 21:20

Phil Pinkston (phillywonka) 25.12.2021 21:20
Has anyone had any issues with Giants Editor crashing when opening a map? Everymap I've tried the program crashes. Can't get any help anywhere and trying to get his resolved. Thank you in advance!

Juan Garcia Burdalo (JuanGB) 25.12.2021 21:37
Hello, I also have the same problem, I have been working on my map and when I want to test it in the game it stays loading at 95%, and even with the previous version of the map it does not load and before yes,
Please help, thank you

Phil Pinkston (phillywonka) 25.12.2021 21:54
you can get further than I can. I open my Giants Editor and import a map she crashes. I can't even work on one.

Tom Henningsen (Dudly) 26.12.2021 00:21
Jeg har samme problem med Windows 11 jeg kan starte Giant Editor op men når man så vil hente et mods ind lukker Giant Editor ned

Matthew Mccaul (Scarecrow) 29.12.2021 13:11
GE 9.0.2 crashed while i was editing an i3d. now everytime i try to reopen that i3d GE crashes. no info in the log.txt except for that the i3d was opened, after that nothing and crash to windows. not happy.

Oliver Sauer (Oli673) 03.01.2022 09:30
Hello, i have the same problems. But at the beginning from 9.0.2 i have no problems. I have work on our mod map , but some days if i start a random i3d or would like start the map i3d the Editor go off? what can i check?
Thank you

Tom Henningsen (Dudly) 03.01.2022 10:22
It doesn't seem that giant editor works in now even though they came with a Texture tool v9.0.0 on 30-12-21
There must be an error on the editor itself that means that when you try to read something into the Giant editor, it shuts down the entire program? In the years I've been using the Editor, I haven't tried this before, so it must be a software glitch that shuts down completely ?????

Marcus Ratcliffe (Racey1977) 03.01.2022 16:27
im having the same problem go to open a map goes back to windows screen

Brummie Farmer (BrummieFarmer) 03.01.2022 17:10
I have had problems with other versions of editor crashing on opening... How i fixed was to go to C:\Users\Your UserName\AppData\Local\GIANTS Editor 64bit 9.0.2 and delete the editor.xml file and relaunch ge and see if that works...

William Devin (BwAIRONDEEK) 10.01.2022 07:00
i can make an object with a primitive shape, save it, reopen it, all good,......import something, crash to desktop.

Tony Hart (griffydam777) 10.01.2022 11:20
Try : goto preferences - change the game installation path.

Gregg Macfarlane (SirCuddlesWorth) 10.01.2022 19:02
Oddly enough, I only get crashes in GE when trying to create a Navigation mesh.

Michael Fowler (mfowler1981) 28.01.2022 02:08
I had the same problem! Tony, I took your advice and checked the game installation path and I changed it from fs19 to fs22 and it worked right away! Thank You!!!

Andrew J Stevens (andyisgood316) 30.01.2022 01:10
I am having the same issue no matter what I try giants editor 9 keeps crashing once open I get as far as the starting screen then when I try and open a map/mod it crashes I just tried uninstalling and reinstalling it did not work still crashes

dlaidlaw 30.01.2022 19:16
I had the same issue, What I did was to alter the install directory by removing the the sub directory after giants software

this is how my directory path looks D:\Program Files\GIANTS Software.

This has fixed my crashing error on opening an id3 file.

Also fixed the editor stuck on starting.

Izaak Norwood (izaaknorwood) 20.03.2022 11:54
mine is also crashing on start up it is getting really annoying i would love have some one help me out with fixing it ?

Ed Propsner (crotchfrog) 20.03.2022 14:38
What steps have you tried already to fix it? Open your editor.xml (located at C:\Users\user\AppData\Local\GIANTS Editor 64bit 9.0.2) and search for <gameinstallationpath>. The entry there should point toward the FS22 game installation location. For example, if you downloaded the game from steam, it should be along the lines of C:\SteamLibrary\steamapps\common\Farming Simulator 22. If you don't know the installation path you can find it by right clicking on the FS22 icon (likely on your desktop) and then selecting "properties."

Terry J. Delaney (Ricebug) 31.03.2022 18:45
I installed everything correctly but the editor will not load nor import any map. Period.

Ed Propsner (crotchfrog) 01.04.2022 13:30
Have you checked the editor_log?

Jordan Meek (JDFarmboy72) 10.04.2022 04:03
Having the same problem, will not load any map i3d at all and will load other mods but cannot display the 3d model. Ive looked in the AppData/Local files but there is no Giants Editor 64bit folder for version 9 like there are for the older versions

Ryan Garrand (Rgarrand) 14.04.2022 04:23
same issues. very new to this modding and i thought it was just bad mods that i could convert but after readying i realize it was my editor.

so i successfully converted a few mods then this started happening the same time. like i said thought it was just bad mods that wouldn't pop up

problem is when i open a mod in editor it will completely close out the screen or "crash" as you all say. i found the folder and deleted the xml editor i believe.

i also watched a YouTube vid with where the path should come from in preferences but i hit apply and then it closed and reopen to them not being saved.. idk what to do thanks

yes ive tried deleting and reinstalling

Ed Propsner (crotchfrog) 14.04.2022 14:18
If you open the editor.xml, you can make changes manually without the need of the editor itself. If you were successfully converting mods when this happened, it sounds like it could be whatever you were working on. There can be errors within mods that will absolutely crash the editor. First try to open a known working mod such as a basegame map or vehicle. If the editor still crashes, then you know the problem is with the editor itself. If it does not crash, the problem is with the mod you were working on. Have you checked the editor_log to see if it gives any indication why this problem is occurring?

Miloš Moravec (Mikenick1989) 17.04.2022 11:27
Editor crash error fixed.
The repair method is described above.
Here is a detailed path: Run editor => File => Preferences => Game Installation => Installation Path
Here you have to choose the path of the game.
If you have a game over steam.
E: / Program Files / Steam / steamapps / common / Farming Simulator 22
If you have a game over Epic
E: / Program Files / my games / Farming Simulator 19

Note that these are just examples. Your paths may be different.

Stuart Macrow (SMACROW2PAC) 09.07.2022 17:07
my map editor keep close down i am try open it i am try make new map

M_k Mcd4 (MKMcD) 10.07.2022 14:24
Are you using the latest version 9.0.3?

Alex Lastname (aabailey) 20.07.2022 18:33
i'm trying to load a vanilla map, alpine, and GE just crashes. using 9.0.3 with a cleaned (deleted) settings folder. the errors in the log are all 'can't load resource' or 'failed to open xml' i've set both the game path and the text editor path. I am able to open vehicles however. just not the map.

Kyle Conlin (kylehoax) 31.07.2022 22:59
My Giants editor keeps crashing when I load a map, any luck? I'm using the latest giants and FS22 map mods any help would be great
really want to start making map mods

Markus Studeregger (ViveDR) 03.08.2022 10:48
Possible fix works for me on "9.0.3"!
Delete your Ginats Editer Folder where your Editer Log is Saved
C:\Users\user\AppData\Local\GIANTS Editor 64bit 9.0.3
Delete this Folder "GIANTS Editor 64bit 9.0.3"
Restart the Editor it will recreate the Folder and if you have an Older Version of GE also installed DO NOT Import the settings from the older Version!!!
and maybe make shure the Driver for your GPU is up to Date.
This worked for me
Hopefully it works for you to!

Darin Lee Foltz (Zuce92) 25.08.2022 06:29
So ya anyone having this problem change your game path in preferences should fix your prob

Reinier G (reinierg) 19.11.2022 20:00
I gave the editor more ram and now its working.

Radek Rad (Tecet79) 30.01.2023 15:55
For me worked when in Giant Editor preferences selected game installation path as was missing. Map I tried edit before that change but crashed without opening works now. version 9.0.3

Cyber Farmer (cyber_farmer) 12.02.2023 18:04
I had the same problem and this is what fixed it for me...

Open the Editor, under "file" tab, click "preferences." Ensure your "game installation path" is correct. For me, it wasn't. Once I changed it to correct path, it now works fine.

Note: Log in to post. Create a new account here.