Community Forum

Beta exporter doesn't work

Forum Overview >> Blender Exporter

CategoryBlender Exporter
Created29.04.2014 23:26


Paul Wittner (unknown) 29.04.2014 23:27
Hi guys,
the new beta blender exporter is not working for me!
Have a clean install from blender 2.70 64bit.
Activate the plugin in the usual way, no errors.
Make a cube with unwrap uv's and add a simple png texture file.
I press the button "I3D Exporter" and nothing happens, no error, nothing!
Or i am to stupid?
please help

Scott Be (unknown) 30.04.2014 02:04
Hi Paul having the same issues as you have. I could be stupid myself :) I have tried several things to get the exporter to function several different blender's but no success :(

Windows 7 for me "clean" install of Blender 2.70 and 2.67 ran the installer and manually install on both but no go for me..

Christian Ammann - GIANTS Software 01.05.2014 12:07
Hi Paul,

What do you mean by "press the button I3D Exporter"? Can you see the I3D Exporter menus ?

Best,
Chris


Mike Prpich (Pirps19) 01.05.2014 19:41
i'm having issues with the new plugin as well i'm getting this error

http://img5.fotos-hochladen.net/uploads/269errornmqp4v2g1r.png

Paul Wittner (unknown) 02.05.2014 00:02
Hi Chris,
i upload a screenshot to my dropbox https://db.tt/SeSIu6oZ
When I click in the blue box "I3D Exporter", there is no menu. Nothing happens.

Regards Paul

edit says:
I'm sooo stupid :D
Have found in the Properties panel, the new export menu. Thx Giants for the new exporter,
this works fine for me, thumbs up. https://db.tt/4iJaGL78

Mike Prpich (Pirps19) 02.05.2014 07:10
ok so i've got the exporter to work but the model i made in an older version of blender i cant get the the materials and textures to show up in giants editor. I also can't get some pipes i've made to export at all. I get this error.

Traceback (most recent call last):
File "C:\Program Files\Blender Foundation\Blender\2.70\scripts\addons\io_export_i3d\i3d_UIexport.py", line 327, in execute
i3d_IOexport.doExportSelecred()
File "C:\Program Files\Blender Foundation\Blender\2.70\scripts\addons\io_export_i3d\i3d_IOexport.py", line 1325, in doExportSelecred
m_exp.exportSelected()
File "C:\Program Files\Blender Foundation\Blender\2.70\scripts\addons\io_export_i3d\i3d_IOexport.py", line 72, in exportSelected
self.export()
File "C:\Program Files\Blender Foundation\Blender\2.70\scripts\addons\io_export_i3d\i3d_IOexport.py", line 81, in export
self._xmlBuild()
File "C:\Program Files\Blender Foundation\Blender\2.70\scripts\addons\io_export_i3d\i3d_IOexport.py", line 965, in _xmlBuild
self._xmlWriteShapes()
File "C:\Program Files\Blender Foundation\Blender\2.70\scripts\addons\io_export_i3d\i3d_IOexport.py", line 688, in _xmlWriteShapes
self._xmlWriteShape_Mesh( m_meshOwner, m_mesh, m_meshID )
File "C:\Program Files\Blender Foundation\Blender\2.70\scripts\addons\io_export_i3d\i3d_IOexport.py", line 724, in _xmlWriteShape_Mesh
m_materialIDs = self._xmlWriteShape_MeshData( m_obj, m_meshGen, m_meshID )
File "C:\Program Files\Blender Foundation\Blender\2.70\scripts\addons\io_export_i3d\i3d_IOexport.py", line 738, in _xmlWriteShape_MeshData
m_mesh.calc_tangents()
RuntimeError: Error: Tangent space computation needs an UVMap, "(null)" not found, aborting


location: <unknown location>:-1

Everything worked fine in 2.62 but now with 2.70 i'm having issues. Is there anywhere i can read up on the changes now with new exporter? Any helpe or advice would be greatly appreciated.

Christian Ammann - GIANTS Software 02.05.2014 15:12
Hi guys,

We have an updated version of the Blender Exporter (5.5.1 Beta) in the download section with some script fixes that should work with all current Blender versions (2.6x and 2.7x).

Best,
Chris

Scott Be (unknown) 02.05.2014 16:13
Thank you Chris for the update and Giants team for the effort of getting the exporter to function with the later versions of Blender.

Was really excited when read the news hope the rest comes together with the exporter.

Thank You
Scott

Mike Prpich (Pirps19) 02.05.2014 18:08
Is there anything i need to do differently to have my textures show up in Giants Editor after exporting from blender. Some pieces of my model will show up textured and others wont


Christian Ammann - GIANTS Software 04.05.2014 11:49
Hi Mike,

Can you send us your Blender file (with textures). We will have a look.

Best,
Chris

Mike Prpich (Pirps19) 05.05.2014 04:54
i figured out what the problem was. In the material options i had the mirror checked which turned everything black in GE. I have noticed tho my texturing doesn't look nearly as good when exported from 2.70 then it did in 2.62. That problem might be in my texturing right now i will see if i can fix it. thanks

Dread Tuga (dread) 06.05.2014 17:57
The beta exporter version in Blender 2.70a shows as 5.5.0 and the version of the download is 5.5.1 maybe thats why i cant access the i3d exporter menus?

Scott Be (unknown) 07.05.2014 02:11
The Exporter options are located in the properties panel "N Key" https://www.dropbox.com/sh/z5wkyw88wfnau1c/2LHTp3y1_s

Bio Medical Extetion (biomex) 24.10.2016 12:52
Hi,

I've an issue when exporting from Blender 2.78 64bit with Blender Exporter plugin v6.0.2 or v7.0.0 and GE 64bit v6.0.5:

Log Output:
-----------------------------------------------
Exported Successfully! C:\Users\Jo Real\Documents\blender\van.i3d
Export time is 1.08155 seconds
Exception ignored in: <bound method I3D_Node.__del__ of <io_export_i3d.i3d_UIexport.I3D_Node object at 0x0000024156B099E8>>
Traceback (most recent call last):
File "C:\Users\Jo Real\AppData\Roaming\Blender Foundation\Blender\2.78\scripts\addons\io_export_i3d\i3d_UIexport.py", line 487, in __del__
AttributeError: I3D_currentNode
-----------------------------------------------

Please help.....




Note: Log in to post. Create a new account here.