Community Forum

New Blender plugin 8.0

Forum Overview >> Blender Exporter

CategoryBlender Exporter
Created01.12.2018 10:43


Marek D. (Marthless) 01.12.2018 10:43
Hello, I have a new version of Blender 2.80.x but after downloading and installing it shows up correctly in the options. But, the problem is that you can not activate it in any way, because it shows the versions as 7.1 and makes me update to the latest version of Blender. I will be grateful for correcting this or explaining what is wrong.

Jorn Hiel (fa285634) 02.12.2018 10:33
2.8 is not a real program yet, its either an alpha or a beta. The current plugin is for 2.7x versions

Marek D. (Marthless) 05.12.2018 15:02
I can say that the new version of Blender 2.8x is supported. But Giants forgot to change the version from 7.1 to 8 :P

Bartek Perkowski (Pyrol) 05.12.2018 16:33
Same in my view ;)

Larry Horse (Larry) 09.12.2018 14:25
"2.8 is not a real program yet, its either an alpha or a beta" By definition being in alpha or beta makes it a real program. But that does not matter to no one in Giants because it's not the shit they work on. So you get the plugin when someone gets made to write it as punishment for something.
No animations, no skinned nodes, Who gives a fuck. The money you cough up for years to buy their games and DLC's is being taken for granted more every year.

Bilbo Beutlin (BBeutlin) 09.12.2018 17:29
With FS you've bought a GAME, not the entitlement to have access to arbitrary tools.
The GE as well as additional utilities are a "waste product" from developer requirements. If they don't have the need to implement certain features, why should they?
The Blender plugin is written in Python. Learn this language and adapt the plugin to your own purposes.

Soile Saarnio (Lyriga) 12.12.2018 22:19
Hello,

Well, what Bilbo said helps a lot some of us whom find script languages to be Hebru to start with. Sighs! Not all of us can script, some of us do not even see logic in any script languages - even if we have high 3D logic abilities. I don't find that answer appropriate.

I have this same (or similar) issue and I have been wondering if it has to do with the fact that my Blender is installed on D:\ -drive instead the usual C:\ - at least the error message comments something about those - even if I have no idea what it means. I attempted to ask about that, but it demanded me to sign in again to make that thread and my had written copy of the error message was lost because of that. So I will just shortly comment here and hope someone has a bit more constructive mentality to help us solve this matter. I think my Editor is the beta version.. as I wanted to work on FS19 map, I haven't even had the game before in older versions.

Thank You,
Soile (Lyriga)

Bilbo Beutlin (BBeutlin) 13.12.2018 00:53
1. If the path to Blender is wrong or couldn't be found, it wasn't installed properly. It should be known, that an install must be executed with full admin. rights - else registry values can't be set.

2. Same for the Blender plugin setup. And during setup there's a readme - the one who reads, will find out the plugin supports Blender upto vs. 2.79.

3. People who make it wrong, are whining in forums about bad software.

Dave Chuckry (CaptainD430) 24.12.2018 01:19
instead of installing with installed use extract to whereever then install from that zip it works this way blender 2.79b

Cameron Mccarthy (Cam223) 05.01.2019 00:26
ok so since it doesnt seem many have given a defined answer to your problem, I figured out if you open the installer and then click extract and send the zip to your desktop, then go into blender and under file>userpreferences>addons, Go install addon from file, then navigate to the desktop (or wherever you extracted the zip to as long as its not in the addons folder) and select it then click install addon from file the plugin should be installed, i have found however that the plugin still doesnt work properly so take it for what it is.

Joe Lindberg (lindbejb) 21.01.2019 20:38
yea it doesn't work, not recognized by blender

Marek D. (Marthless) 27.02.2019 12:39
Does anyone at all with the Giants moderate this page? There has been so much time since its release and there is still silence, it is already a slight exaggeration!

O.wiesemann (TopAce8888) 10.04.2019 11:32
@Cameron Mccarthy: Thanks, that did the trick.

Zachary Benson (DS_Gaming) 01.06.2019 14:47
Blender 2.8 is still in beta and updates daily, its not feasible for giants to continually update the plugin until its released as it could break the next day. The current plugin is more than likely just a placeholder until release.

Sr Williams (srwill2010) 01.06.2019 16:14
Workaround:
✓ Blender: Make sure you have the FBX exporter
add-on enabled (it’s enabled by default). Then
choose File➪Export➪Autodesk FBX (.fbx) from the
menu. Options for the FBX format are available on
the left region of the File Browser.
Best way to not have to rely on .i3d file format if using Blender 2.80.
Blender 2.79B does support, and it works, the .i3d plugin from Giants.

Jason Oppermann (Falcon70) 19.06.2019 09:56
ahhh the Fbx works great, at least till 2.8 is "official" i've installed the blender exporter as well and it did not come up in the export options for *i3d, it still only show *.x3D

Mana Tee (Manatee) 06.08.2019 12:47
So for dummies (like me): I Export *.FBX in 2.8, open in 2.79 and export to *.i3d?

Jorn Hiel (fa285634) 07.08.2019 18:14
faster work around -> file / append --> object catogory




Zachary Benson (DS_Gaming) 09.08.2019 23:13
Giants editor will import a .FBX from blender


Note: Log in to post. Create a new account here.