Community Forum

Error in log for map

Forum Overview >> Farming Simulator 2013

CategoryFarming Simulator 2013
Created09.05.2014 14:04


Mirko C. (unknown) 09.05.2014 14:06
Error: Can't load resource: data/maps/sounds/churchBell01.wav
Error: Can't load sample data/maps/sounds/churchBell01.wav.

After entering the map pops up this error as I do to correct it?


Emil Drefers (giants.edrefers) 10.05.2014 20:07
Hi,

well, you have two possibilities to solve this ...
Either you place a sound with the appropiate filepath in the map or you delete the 'audio source' in the map.
I guess the later is the way to go, as you propably don't have any matching soundfile at hand.

To delete the 'audio source' you just have to open the map with the GIANTS Editor.
Enable the display of audios sources by clicking on:
Menu -> View -> Show -> Audio Sources
All these red spheres/circles are audio sources.

To make an audio source 'clickable' aka 'selectable', you have to enable:
Menu -> View -> Selectable -> Audio Sources

If you move the camera close enough to an audio source you will notice, that there is a 'red wireframe speaker' symbol.
You can click that.

With the 'Attributes Panel' opened you can now see in the Audio panel which file is used by this audio source.

Now, you can find the one which refers to the mentioned and missing file.
Probably it is somewhere near a church? But I don't know for sure ;)

Good luck finding the source.

Best,
Emil




Mirko C. (unknown) 14.05.2014 11:40
Thank you for your reply I have done several tests with little result.
the error persists if left the Church on the map ...
the solution I see really hard ...



Scott Be (unknown) 14.05.2014 16:47
Hi Mirko

Did you delete the user attribute thats calling for the sound ? Just removing deleting the audio source will not remove the user attributes thats calling for the sound which results with the same error in the log.

With the user attributes window open go to the church/churches selecting/clicking on the building. Then find in the scene graph "should be highlighted" while selecting each part/mesh in the scene graph that make up the church look at the user attributes window till you find the mesh that has the attribute.

Then simply click the delete beside the attribute removing the. This should fix your log error if there is more then one church be sure to delete also.

The churchBell01.wav existed in fs11 for the church that was on the default map. I think someone uploaded the church as a downloaded map object for fs13.

Good Luck



Mirko C. (unknown) 15.05.2014 13:35
User attributes theres only oncreate for the clock of the Church looks like this collback is a ghost, I can't correct the mistake in the old map I could fix it by adding a line to the xml file.


Scott Be (unknown) 15.05.2014 17:56
The onCreate for the clock is what will need to be removed to get rid of the error in the log. Which will result in a non functional clock but your error will be gone..

Mirko C. (unknown) 16.05.2014 11:59
Thank you for your reply I will try to do this test, how do I fix the .lua file such a thing?


After this change, it became another mistake that prevents me to load the map, only to have changed in my map the terrain.

Error: LUA running function 'loadSharedI3DFileFinished'
D:/code/lsim2013_desktop/build/finalbin/dataS/scripts/vehicles/Vehicle.lua(135) : attempt to perform arithmetic on local 'terrainHeight' (a nil value)
Application exit request forced.


Scott Be (unknown) 20.05.2014 16:18
The error you provided here had nothing to do with removing a simple user attribute...

The 'loadSharedI3DFileFinished' seems to me you have placed the shapes file and the i3d in different locations and tried to open in GE/Game.

Removing the user attribute for the clock to get rid of the sound error is a fairly simple task.


Note: Log in to post. Create a new account here.