Community Forum

Error in map help

Forum Overview >> Farming Simulator 2013

CategoryFarming Simulator 2013
Created18.06.2014 10:11


Mirko C. (unknown) 18.06.2014 10:25
Help me please....
loaded my map the time is long why?
I have only changed the terrain for more detailed objects...
to error in log is:

Error: LUA running function 'loadSharedI3DFileFinished'
D:/code/lsim2013_desktop/build/finalbin/dataS/scripts/vehicles/Vehicle.lua(135) : attempt to perform arithmetic on local 'terrainHeight' (a nil value)


I would also add the able to dry the grass with the spraying machines how can I do?

Emil Drefers (giants.edrefers) 18.06.2014 14:31
Hi Mirko,

the prolonged time for loading your map is very likely caused by the error.

Seems like the map got messed up.
Eventually you did something wrong when editing it.

Could you please explain in detail what you changed and especially what you mean with "more detailed objects" ?!


About your second question: Drying grass by spraying 'what' on it?
I can't imagine how that should work.
But you can try to use the 'windrower specialization'.

Best,
Emil

Mirko C. (unknown) 19.06.2014 10:11
Hello Emil

I have exported a new ground, at another more detailed map, following this with the editor I just inserted the verie grass type present in the soil.

Did this and finish the map I created the mod with all its parts but loading in the game gave this error.


In reply to the second question I don't understand what you mean

Emil Drefers (giants.edrefers) 20.06.2014 08:00
Hi Mirko,

what is a 'more detailed map'?
A map with a different 'terrain resolution'?

Can you provide us links to your map and the map you got the terrain from, so that we can reproduce your steps 'exactly'?



Concerning your second question:
You need to create your very own mod vehicle and propably write a script for it.
But, in general the 'windrower' specialization
(http://ls-mods.de/scriptDocumentation.php?lua_file=vehicles/specializations/Windrower)
allows you to change cutted grass into windrowed (dried) grass.
You can take it as a reference when you write your own script or you use the specialization for your mod vehicle directly, but then you would propably still need a script depending on what your machine should do and look like (particle systems ? ;) )

Best,
Emil



Mirko C. (unknown) 24.06.2014 10:20
Hello

For me 'more detailed map' is having more types of different grass than the original map.


The map from which I exported the soil, to import it into my made with a dem original, is OGF_AUS_MAP downloaded on the web..

Thanks to the second question but I found a similar mod what I tried to do.

Emil Drefers (giants.edrefers) 24.06.2014 14:30
Hi,

well, as i don't know what you've changed on your map exactly (how you integrated the new layer), it's hardly possible for me to say what you did wrong.
But here are a few suggestions what could have gone wrong, respectively what you should take care of:
- copy the entry of the layer into your map by using a texteditor (n++ is pretty handy ;) )
- copy the texture files and the density files of the layer into the corresponding directories
- take especially care of the Ids like fileId, materialId and if used blockShapeId
Note: It is very likely that you have to adjust these Ids!
- save the map in n++ and load it with the GIANTS Editor, read error messages carefully

Maybe have a look into an other map, wich also uses more layers and try to understand how everything works and what each entry in the 'Foliage*Layer' means.

Best,
Emil


Mirko C. (unknown) 01.07.2014 10:16
These steps have been done correctly, the problem occurred with the new mod forest (Beta) after having played in the original map this error occurred with the growth of plants having perhaps exceeded the limit of plantations.

So perhaps by importing a rich soil of different types of grass does not allow uploading?

How can I make the map more accurate your PDA?

Emil Drefers (giants.edrefers) 04.07.2014 08:36
Hi Mirko,

it seems to me, that you are mixing things up ...

First of all, you should always test mods independently.
That means, if you've created a map, than test it without the forst mod first.

If you get errors by using the forst mod we can't help.
We are not the authors of the forest mod - please contact the authors of this mod.


Second, you can import/integrate different types of layers into a map - that's no problem, you just have to do it correctly.
It is also possible to integrate more than one new layer.


Your question about map and pda is hard to understand.
Do you want to know how to create an image for the map view in the PDA?


Best,
Emil

Mirko C. (unknown) 08.07.2014 10:42
If the map and the forestmod have been tried separately.


For the question on the PDA is it like in the original map the PDA has a detailed map how do I do it for my map?

Emil Drefers (giants.edrefers) 09.07.2014 08:50
Hi Mirko,

about the error message in your very first post:
It seems, that you have done something wrong when you intgerated the new layer.
Or there is something else wrong/corrupted in your map.
The message itself can't be used to locate the reason for the problem.
It just says that the terrain of your map is somehow broken.

About the PDA:
You have two options:
1) Use the GRLE Converter (to be found in the downloads section here at GDN).
With this tool you can convert the .grle files to .png
After that you can use these image files in an image editing program to create a pda map.
Disadvantage of this option: you will not have any objects (houses) visible on the map.

2) Open your map with the GIANTS Editor.
Set up the attributes of the camera so, that it looks directly downwards and causes a minimum of projection artefacts.
Now take several screenshots (we used 64).
Finally cut and merge the screenshots in an image editing program of your choice

Best,
Emil

Mirko C. (unknown) 09.07.2014 17:56
Hello
With the Giant's editor (I had no errors once saved in editor) I imported the new ground with several layers finish complete the operation I zipped everything up and put in your mod.

I tried to load the map but was not charged and was the error log at the beginning of the post I specified.

I did alter evidence to reduce the types of grass but always the same error persists

Emil Drefers (giants.edrefers) 10.07.2014 08:25
Hi,

could you provide us a download link to your map so we can have a look?

Best,
Emil

Mirko C. (unknown) 10.07.2014 18:55
excuse me but I did not put in my network map, you refer to the map from where I took the ground?

Emil Drefers (giants.edrefers) 11.07.2014 08:15
Hi,

the map from which you took the ground (only a layer?) is not really necessary, because it works fine, right?
The error somehwere occured when you imported the ground (a layer?), so i would need to see your map to be able to help you.

Best,
Emil

Mirko C. (unknown) 14.07.2014 11:04
It works well in terrain map from where I got it.

Had in ls-network a modified planter for corn, because it was my first mod to understand how to do although I haven't modeling a good knowledge (I created a rimorchiella with SketchUp 8)
but I have problem with blender in converting it for giants editor

How can I make you have the zip of the map without that others can download?

Mirko C. (unknown) 24.07.2014 18:33
Hi,

I try to explain the facts in my map I opened with Giant's edit the original map and I introduced the map from which I was interested in the various types of grass found in map always with Giant's published over the work I tried it and it gave me the error mentioned in the first post (you can model your way with only the giant s? no convert the block for blender)

Emil Drefers (giants.edrefers) 29.07.2014 17:53
Hi,

honestly speaking i have problems to understand what your trying to say.

But be aware that importing new foliages can not be done with the GIANTS Editor.
Therefore you need to edit your map manually (e.g. with the notepad++).

regards,
Emil

Mirko C. (unknown) 20.08.2014 13:56
hi,

ok new problem in Giant editor is:

warning: distance colors with a bigger lod texture than the density map are not supported yet.

likely that the error is caused by this?


Note: Log in to post. Create a new account here.