Community Forum

why isn't my giants editor 7.0.5 opening my map

Forum Overview >> Farming Simulator 17

CategoryFarming Simulator 17
Created03.03.2017 22:14

Gordon Champagne (bikerider84550) 03.03.2017 22:23
Anybody else having problems with GE not even showing an attempt at opening maps ? it shows the little 4 box tutorial thing that also comes up when you open GE but no map ......

Christian (Scharphorn) 08.03.2017 16:35
What map are you trying to open?
Most of the time its not opening maps, because it got errors in it it can't solve.
At least that what i found out with my map.

Gordon Champagne (bikerider84550) 09.03.2017 21:51
It's not one map - it's not opening any map and actually my original post was wrong where I said " it shows the little 4 box tutorial thing that also comes up when you open GE but no map " . It shows that window but doesn't have the map window that usually opens together with it . This shows up but then crashes and I can't do anything with it . I've deleted / removed GE and downloaded it again but it still does the same thing .

Emil Drefers (Unknown) 10.03.2017 16:35

sometimes it helps to open the editor first and load the map afterwards by using (File -> open).

Please also check if you are using the latest version of GE.


Gordon Champagne (bikerider84550) 11.03.2017 05:42
That did get the "getting started" window to open without crashing but still no map and I'm using G.E. 7.0.5

Emil Drefers (Unknown) 13.03.2017 16:20

could you post your log.txt of the editor?

Note: the GIANTS Editor needs a proper (dedicated) graphics crad to work correctly.


Gordon Champagne (bikerider84550) 13.03.2017 20:11
Where would I find / how would I get to the log.txt ?

Emil Drefers (Unknown) 15.03.2017 07:49

my bad, it's the editor_log.txt

You can find it in the following folder:
C:\Users\<username>\AppData\Local\GIANTS Editor 64bit 7.0.5


Gordon Champagne (bikerider84550) 18.03.2017 22:04
Ok well here's a copy of the log :

GIANTS Engine Runtime 7.0.0 (13783) 64bit (Build Date: Nov 21 2016)
Copyright (c) 2008-2016, GIANTS Software GmbH (, All Rights Reserved.
Copyright (c) 2003-2016, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 7.0.5
Main System
CPU: Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz
Memory: 32706 MB
OS: Windows NT 6.1 64-bit
Physics System
Version: 5.9.5
Thread(s): 2
Sound System
Driver: OpenAL Software
Render System
Driver: OpenGL
Card Vendor: NVIDIA Corporation
Renderer: GeForce GTX 770/PCIe/SSE2
Version: 4.5.0 NVIDIA 378.66
Shader Version: 4.50 NVIDIA
Max. Texture Layers: 16
GL_AMD_depth_clamp_separate not supported
Started 4 threads for threadpool 'Render threadpool'
Hardware Profile
Level: Very High (forced)
View Distance Factor: 1.300000
Shadow Quality: 2.000000 Size: 4096 Filter-Size: 16
Shader Quality: 3
Skip Mipmaps: 0
LOD Distance Factor: 1.300000
Terrain LOD Distance Factor: 2.000000
Terrain Normal Mapping: Yes
Foliage View Distance Factor: 1.600000
Foliage Density: 0.500000
Volume Mesh Tessellation Factor: 0.750000
Tyre Tracks Segments Factor: 4.000000
Max. Number of Shadow Lights: 5
Max. Number of Lights: 512
Max. Number of Lights Per Cluster: 32
Check for updates (
C:\Users\Gordon\Desktop\Goldcrest_USA\maps\map01.i3d (55540.57) ms

Jacob Zimmerman (Unknown) 31.03.2017 00:17
This is the same as mine. except with vehicles cause they wont load up i cant see it the only thing that shows up is the circles of yellow and blue and the green camera but no tractor

Emil Drefers (Unknown) 31.03.2017 06:45

the log looks good to me.
I will forward the problem.


Noah Conley (Unknown) 01.04.2017 04:09
i have the same problem. y vehicles wont show up. i have tried everything i can think of

Victor Alexandre De Souza Santos (Unknown) 17.07.2018 20:52
vesao 7.0.5

Note: Log in to post. Create a new account here.