Community Forum

help with helper

Forum Overview >> Farming Simulator 17

CategoryFarming Simulator 17
Created08.05.2017 11:04

James Biddulph (Unknown) 08.05.2017 11:09
I am in the process of creating my own map and have created a field using various tutorials found on the i-net, the fields operate correctly until you try and hire a helper and I get the message 'Helper A has completed the task' without it doing anything, I have tried going ingame and manually harvesting and cultivating the ground first but the helper still refuses to work. Is this a known bug and can we expect it to be sorted soon, or is there something I am not doing that I am suppose to.

I am using the new 7.1.0 editor to create the map.

I know help on here is very scetchy but please if there is a way someone please help.

Emil Drefers (Unknown) 09.05.2017 07:08

the helper might not want to start due to some collisions around him.
Could you show us a picture of the situation?
Eventually he starts to work if youd start him in the middle of the field? Please try different start position all over the field.


James Biddulph (Unknown) 09.05.2017 10:35
There are no fieldBorderHelperCollisions or objects of any kind around the harvester when I press 'H' for helper, and I have tried different starting positions and it just does not seem to want to start, I just get the 'Helper A has completed thier task'. I have tried everything even importing a field from your Map01 map in the game, everything was done the way it should have been. I do not know how to show an image on here, if you could let me know how I will.

Could it have anything to do with the map01.i3d.colMap grle file, I am not sure what to do with 'Create ground collision map' script maybe it is to do with that I do not know, but it just does not want to work.

Emil Drefers (Unknown) 10.05.2017 07:05

well, the helper needs a valid field (setup by transformgroups) and a valid ground (terrainDetail layer and foligae state).

Did you test this with a default combine?
On a default fruit type (wheat)?

I would recommend that, just to make sure that the problem is not caused by a mod.
So, it is probbaly also a good idea to disable all mods (except your map) when you wanna test the AI.

To upload an image just choose an image hoster (e.g., upload your screenshot and post the linmk to the image in this thread.


James Biddulph (Unknown) 10.05.2017 08:05
Here are some images showing how I have the field set up

These show (hopefully) that I have the field set up correctly, can you please advise. Oh and I tried without any mods in the mod folder just my map, still get the same thing. And yes I am using a default harvester that comes with the game and the fruit type is set on wheat (fully grown flags 4,5 & 6)

Also perhaps you can help with another problem I have come across I am trying to add a nighttime ambient sound to the map, in the 2015 version all you needed to do was put in the attribute soundCategory="night" but that no longer exists in the 2017 version, how do I set a sound to play only at night.

Emil Drefers (Unknown) 10.05.2017 12:24

thanks for uploading the images!

hmmm hard to say where the actual problem is.

Field definition looks good to me. For testing purposes I would leave the user attribute "ownedByPlayer" to true, so the field jobs don't interfer with it.

Did you apply the "terrainLayer" to the field?
In the images it looks like, but eventually you have a texture layer which looks like that.
Try to set some 'sown ground', maybe that resolves the problem.

Another idea ...
Seems like you are using some meshes for the "high distanace mountains".
Please make sure that they are seperated (or any other object which might be really huge).
A mesh (with collision) which spawns all over the map will interfer with the AI heavily.


James Biddulph (Unknown) 10.05.2017 18:32
Thanks Emil working now, it was as you said one of the distant hills that was interfering with the AI, once I removed it it worked fine, so sorry my fault not Giants, brilliant version this by the way, thanks again.

Oh and I sussed out the night ambient on my own I used the code below and it works whether right or not :)

<sample type="basis" file="sounds/ambient/nightAmbient01.wav" volume="0.40" indoorVolumeFactor="0.25" flags="0" mask="14" />

I added the code in case someone else needed to know how I managed it.

Thanks again for the prompt and helpful replies.

Note: Log in to post. Create a new account here.