Community Forum

wierd texture problem

Forum Overview >> Farming Simulator 17

CategoryFarming Simulator 17
Created14.05.2017 22:02

James Biddulph (Unknown) 14.05.2017 22:06
I have come across a wierd problem with bush textures, if I export the bushes from the base maps in the game root folder and import them into my map they behave normally BUT if I create a transform group and cut and paste them into there they disappear (you can see the mesh outline but no textures,) if I cut and paste them back to the base level of the map they reappear, has anyone come across this problem before and if so how did you fix it. So far it is only happening to bushes, the trees and other objects behave properly, all shaders are in there and up to date. But surely if it was a shader problem it would not show outside the transform group.

Tim Derks (timmiej93) 15.05.2017 00:33
What you are describing indicates that the visibility of the transform group is set to false (so invisible). In GE, visibility is hierarchy based. If you set the visibility for one thing in GE to false (so make a transform group or an object invisible), that will make all children of that object invisible too. This should be fixed by switching the visibility of the transform group to true.

James Biddulph (Unknown) 15.05.2017 07:07
What a bloody fool I am, did not even think of checking that, thanks mate.

Another problem I have is I am trying to use the stones from the original map but after exporting I get error messages below...

Error: Can't load resource 'C:/Users/James/Documents/My Games/FarmingSimulator2017/mods/FS17_Hoptons_Farm/maps/Models/nature/maps/textures/terrain/grass_diffuse.png'.
Error: Can't load resource 'C:/Users/James/Documents/My Games/FarmingSimulator2017/mods/FS17_Hoptons_Farm/maps/Models/nature/maps/textures/terrain/moss_diffuse.png'.

I have tried creating the folder in the directory the error shows but this does not help.

Anyone any ideas?

Tim Derks (timmiej93) 15.05.2017 13:18
Are you sure the texture files are in the exact path that the errors indicate?
You can also open the i3D file of the map in a text editor, search for "grass_diffuse" in the <files> list, and change the path to the texture file there.

James Biddulph (Unknown) 16.05.2017 07:26
I am pretty sure it is the shader that is asking for these files and yes they are in the same location as the shader is asking, I have tried putting the said files in different locations but still get the same rsponse, it is as if the game is not seeing them, this is only happening with the stones at the moment.

Note: Log in to post. Create a new account here.