Community Forum

Normalmap problem, and no cubemap

Forum Overview >> Farming Simulator 17

CategoryFarming Simulator 17
Created27.05.2017 11:54

Michael Dirkmann (_pAre) 27.05.2017 11:54
hi, i have Problems with exporting my 3d models. for the Details i make the normal map with photoshop and the nvidia plugin. this are my regular Setting:

after that i add the normal map in 3ds max to the material. in 3ds max is everything fine:

but wenn i Export, i get this strange behavior:

the texture seems to move when i rotate the view. what is the reason for this? with the other objects with normalmap i don't have These Problems.
Here are Pictures without the normal map, as you can see the texture doesn't "move":

hope someone can help me.

Emil Drefers (Unknown) 29.05.2017 06:53


Can you please double check which shader you are using and what settings the final material in the i3df file has.
Compare that to a building from our default maps and you should get some insights.


Michael Dirkmann (_pAre) 29.05.2017 21:22
Actually at the Moment the Building has no shader. only the Standard texture files like in 3ds max.

what i found out, that it musst be a Problem with the normal map. other normal maps which i do not make with the photoshop plugin work. so i tried to convernt the normal map i made with photoshop with the other program and after the conversion the normal map works propely in i3d.

so it musst be a Problem with the nivida photoshop plugin or the Settings i use there. anyone a Suggestion which Settings i should use there?

Tomas Dostal (Unknown) 30.05.2017 08:20
try to use xnormal plugin for photoshop.

with this kind of setting:

Im not sure, but check if you dont have alpha channel in normal map, this also could cause some issues.

Michael Dirkmann (_pAre) 03.06.2017 11:26
the tip with the Alpha channel was right. for test i only used a png file, and this file has transparency. so i saved the png as an dds in DTX1 (without Alpha channel) and the Problem was solved.

but i will also try the xnormal plugin. Looks good.

Note: Log in to post. Create a new account here.