Community Forum

Fill Volume

Forum Overview >> Farming Simulator 17

CategoryFarming Simulator 17
Created26.07.2017 03:05

David Hinton (Unknown) 26.07.2017 03:05
I am currently trying to create fill Volumes for some combines that I have been converting. I've created simple shapes to fit in the grain tanks, and I have added the scripting in the xml necessary. I have even been successful on one combine, but when I repeat everything I did for the next one, I am having no luck. One of two things happens, if I try to load a game that the combine is in, the game crashes. If I start a fresh save and buy the combine, everything works fine until I begin harvesting. When I begin harvesting, nothing shows up in the grain tank and I get the following error:

Warning (Script): Unknown entity id 0 in method 'setVisibility'.
LUA call stack:
dataS/scripts/vehicles/specializations/FillVolume.lua (71) : setVisibility
dataS/scripts/vehicles/Vehicle.lua (627)
dataS/scripts/BaseMission.lua (767) : load
dataS/scripts/BaseMission.lua (914) : loadVehicle
dataS/scripts/shop/BuyVehicleEvent.lua (88) : loadVehiclesAtPlace
dataS/scripts/network/Connection.lua (77) : run
dataS/scripts/gui/ShopScreen.lua (1035) : sendEvent
dataS/scripts/gui/ShopConfigScreen.lua (467) : update
dataS/scripts/gui/elements/Gui.lua (306) : update
dataS/scripts/main.lua (1872) : update

I've named the plane fillVolume and the shape is named fillVolumeShape. The material is set as lambert1 with diffuse colors set at "0.498039 0.498039 0.498039 1" as they are in the fillVolumes in the default machines. The object is simple in shape, and to test if it was object complexity I even tried a basic cube and it did not work. All of my objects were made in blender. I can not figure out just what I missed.

Emil Drefers (Unknown) 26.07.2017 07:09

the GE offers an option to test if a given shape/mesh is valid for the creation of a fillVolume.
Menu -> Scripts -> Vehicles -> Fill plane -> ....
You can also open the script editor window and run the scripts from inside there.

Anyway, when we have a look at the FillVolume.lua:
and take your error message into consideration it is very likely that the fillVolume could not be created.
So, please check if you can create the fillVolume in the editor.


David Hinton (Unknown) 30.07.2017 21:46
Emil, I just upgraded to GE 7.1.0 and I do not see the feature you mentioned about checking in GE to see if the fillplane can be created.

R Harris (Rambow145) 02.08.2017 04:05
I Am getting the same error and I would guess after making and remaking the fillVolumeShape all kind of ways for over 6 hours we can't make the shapes to fit our dump beds, And I don't have the script in the editor And I have no clue how to even code one to get it to work. I have went in to the i3d with the notepad++ and set all code the same still nothing. I used Maya 2016 and I know this shouldn't be that hard but I have no clue why the game is not reading it. I read this *The fill volume has to have a flat parts a bottom and top that is parallel to each other. Plus the Geometry name has to bee fillVolumeShape* but this seems to be wrong because if you look at the metaltech pp20 fillVolumeShape this is so close to what I need but I can't get any thing to work. But I can take the ingame ones and put it on my truck and it works. I can resize them and they still work. I have looked at the lua scripts and they all read to me that the fillVolumeShape is no where to be found but It's like soon as I bring it out of Maya it breaks it. I could use a tip on what I am doing wrong Thanks. My error C:/Users/Rambow145/Documents/My Games/FarmingSimulator2017/mods/Fs17_dodge3500_dump/Dodge.i3d (193.22) ms
Warning (Script): Unknown entity id 0 in method 'setVisibility'.
LUA call stack:
dataS/scripts/vehicles/specializations/FillVolume.lua (71) : setVisibility
dataS/scripts/vehicles/Vehicle.lua (627)
dataS/scripts/utils/Utils.lua (1138) : asyncCallbackFunction
Error: Running LUA method 'loadSharedI3DFileFinished'.
dataS/scripts/vehicles/specializations/Trailer.lua(159) : attempt to index a nil value
Application exit request forced.
Application exit request forced.

I did try hard to work this out my self.


Emil Drefers (Unknown) 04.08.2017 09:31

ups, my bad. The script seems not be available in the public version.
I hope we change that in the future version of Giants editor.

Anyway ...

Here's what I would recommend as a process to test your fill volumes ...

1) first create a very simple object in maya (a cube should be fine)
2) export your vehicle and fix all error/warning messages
3) set up the .xml file of your vehicle
4) start the game
5) buy your vehicle
6) check your log for errors
7a) if no errors, test the behavior of the fillvolume
7a) if there are some errors, use some console commands to reload the vehicle, namely:
gsDeleteAllvehicles - this will remove/sell all your vehicles
gsCleanI3DCache - this will clear the I3D cache
=> adjust whatever is needed and buy the vehicle again to test it


R Harris (Rambow145) 13.08.2017 07:37
Thanks ;)

Thomas A. (thediabl0) 24.08.2017 13:43
gsDeleteAllvehicles or gsDeleteAllVehicles command not found.

Joshua Branson (Unknown) 17.09.2017 03:01
Hey guys, I have found that the bottom of the fillvolume, has to be level with the 0 axis, the very center of the grid. I have made heaps myself that work

Kenny Je (kenny456) 16.02.2023 11:57
Hi i want to create own mesh for fillVolume in FS22 but got this error in game:
Error: Fill volume input mesh has no faces in the top plane of its bounding box.
2023-02-16 11:50 Warning: fillVolume 'tempPart.009' could not create actual fillVolume in ... Simplifying the mesh could help

Note: Log in to post. Create a new account here.