Community Forum

FS19 Terrain not showing in Custom Map

Forum Overview >> Farming Simulator 17

CategoryFarming Simulator 17
Created25.11.2018 05:21


Earl Falcon (FalconModding) 25.11.2018 05:21
I made a map for FS19, and in the Editor the Ground shows, But if I load my map into the game, there is not ground...
I've tried searching for the answer and fix but have not found anything, Ive also tried searching for the same thing for FS15 and 17 but still no luck. So I'm here asking, Ill show you a Screenshot Link --> http://prntscr.com/lmmozn

Anyhelp would be greatly Appreciated.

Thankyou.

Bilbo Beutlin (BBeutlin) 25.11.2018 13:23
The FS19 now needs a lot of auxiliary files for the game, most of them xml.
See first at all the game's log.txt for errors, espec. missing files.

Bartek Perkowski (Pyrol) 04.12.2018 19:52
I think it's because of ground textures are replaced - I replaced every ground texture with my satelite photo and also; I can see it in GE but not in game - what is more: I can increase size to 4096x4096 but then when I load map game crashes (I'm able to see it in GE).

After I updated to GE 8.1 I discovered that also in GE I can see transparent terrain - console says that cannot load shaders (or sth like this) but I'm courious about these line (2darray instead of 2d):
Texture 'TerrainDiffuseTextureArray' has wrong type (2darray instead of 2d) in 'terrainPatch13x14_mat'.

https://pastebin.com/k4evi35t


Solution:
@Earl Falcon
https://gdn.giants-software.com/thread.php?categoryId=4&threadId=6503
This helpe: Moving shaders folder from FS19 root into my map folder (That's because I used ready eampty map)


Jason Lane (jalane) 07.12.2018 08:44
Game now requires shaders to be in the game dir. ie... $data/ , this should eliminate all errors. I had the same errors till I changed the shader file path.


Note: Log in to post. Create a new account here.