Community Forum

Given functionName 'processPlowArea' not defined. Please add missing function or specialization!

Forum Overview >> Farming Simulator 19

CategoryFarming Simulator 19
Created24.06.2019 10:00

Lorenzos (lorenzoita) 24.06.2019 10:00
Good morning everyone,
I get this error - "Given functionName 'processPlowArea' not defined. Please add missing function or specialization!" -
and I can't find the cause.

The vehicle type is "plow".
I also tried to add the specialization with a new vehicle type, but it doesn't work.

<type name="SuperCraker" parent="baseGroundTool" className="Vehicle" filename="$dataS/scripts/vehicles/Vehicle.lua">
<specialization name="plow" />
<specialization name="cultivator" />
<specialization name="ridgeMarker" />

This is the workArea lines

<workArea type="plow" functionName="processPlowArea" >
<area startNode="workAreaStart" widthNode="workAreaWidth" heightNode="workAreaHeigth"/>
<groundReferenceNode index="1"/>

Any suggestion?

Bilbo Beutlin (BBeutlin) 24.06.2019 11:41
I think the combination "plow" AND "cultivator" won't work.
Perhaps try out with different workareas for each.
But I assume you would need a custom LUA script for such.

Lorenzos (lorenzoita) 24.06.2019 12:17
I tried with only plow specialization also, but it doesn't work.

Bilbo Beutlin (BBeutlin) 24.06.2019 16:45
Change the modDesc <vehicleTypes> : if you have a "parent" you don't need "className". Maybe this 'doubling' causes strange behaviour.

Also take a default plow as template and compare stepwise the xml tags/attributes.

Lorenzos (lorenzoita) 24.06.2019 17:34
No difference. The problem is that I get that error even if I use standard vehicle type 'plow'.
I also compared the xml of a default plow, no difference at all.

Bilbo Beutlin (BBeutlin) 24.06.2019 18:23
Difficult to say without seeing the complete files.
It can be an error in i3d, eg. the area definition.
Also double-check the assignments in xml <i3dMappings> for exact accordance to i3d.
Look also for the <groundReferenceNodes> entries.

Might be also a simple typo anywhere in xml.

Lorenzos (lorenzoita) 24.06.2019 18:40
Yea, I understand it's difficult without seeing the files.
With processCultivatorArea (and cultivator as vehicleType) it works without any trouble, but inexplicably with processPlowArea I get that error.
I double-checked the xml for any mistake without result. The workareas in the i3d seems correct.

Probably it's a stupid mistake somewhere.

Lorenzos (lorenzoita) 26.06.2019 20:14
I solved the mystery :)
I've got a vehicleConfiguration for add a second "designConfiguration", I forgot to change the vehicle type from 'cultivator' to 'plow'

Thanks for the help

Note: Log in to post. Create a new account here.