Community Forum

Map height

Forum Overview >> Farming Simulator 19

CategoryFarming Simulator 19
Created06.11.2019 14:06

Ola Haldor Solvik Voll (OlaHaldor) 06.11.2019 14:06
I'm running into a quite annoying issue with map height.
I have converted LIDAR scans of a valley, which I'd like to use. The area is about 4x4km in the real world, which I'd like to have ingame. I've figured the sweetspot for real world distances inside the game is somewhat between 2K and 4K map.

Regardless, I am unable to retain the real world (or close to) height of the surrounding mountain. It comes into Giants Engine as way too flat, even though the DEM file has the full spectrum from black to white. I'm at a loss of what to do. The mountains are important for lumber, while the valley itself is where the farmlands are.

This is ideally what it should be like:
(scaled 1.5 times in Y, but that won't stick when you get into the game..)

And this is what it actually is in the engine/ingame:

Is it at all possible to do this?

Bilbo Beutlin (BBeutlin) 06.11.2019 15:25
After you have scaled something important, you must normalize/freeze the scaling (Edit -> Freeze Transformations)

You may also experiment with the
<TerrainTransformGroup name="terrain" .. heightScale=

Ola Haldor Solvik Voll (OlaHaldor) 06.11.2019 17:25
Freeze transform on a terrain does nothing but reset the scale. Does not work.
i checked the height scale setting, which defaults at 255.
it does not add to the height, but seems like the heightmap get a bit more detail.

If you know for a fact either should work, please tell me what pitfalls I might have been caught in. This is pretty frustrating to say the least.

Bilbo Beutlin (BBeutlin) 06.11.2019 19:57
Set testwise (for comparison) the <TerrainTransformGroup name="terrain" .. heightScale="1000" and look.

On the other hand you could also edit the heightMap.png in a paint program, eg. playing with contrast or gamma.

Ola Haldor Solvik Voll (OlaHaldor) 06.11.2019 21:59
I have tried adjusting levels too. So it's not possible to do anything with how the engine interprets the heightmap, but adjust the heightmap itself? That blows! :(

I replied in a video instead of text. I feel that's easier with this issue.

Ola Haldor Solvik Voll (OlaHaldor) 06.11.2019 23:47
Forgive my ignorance. I adjusted the xml heightScale to 512, and *then* launched Giants Engine. That seemed to work somehow. Need to test thoroughly, but it might be on the right track. Thanks :)

Note: Log in to post. Create a new account here.