Community Forum

animals not appearing in pens after purchase...

Forum Overview >> Farming Simulator 19

CategoryFarming Simulator 19
Created24.11.2019 03:25

Adam F Clark (afcbillsfan) 24.11.2019 03:25
Nor do they show up in menu page for animals. Just horses and pigs, though. Chickens, sheep and cows all appear, and are shown in the menu page. I am working on a personal edit of Rolling Hills and I have animal pens loaded thru the defaultItems xml, all but horse and pig work. I should state here that the horse and pig pens I have used show up ingame, and work in every way, except that the animals, when purchased, never appear, either in the pen, or in the menu. I have tried buying and placing the pens ingame, same thing, all animals appear in pens but the horses and pigs. have tried several different mods for each, same result every time. I am sure there is something I am doing wrong, so am posting here to see if anyone has a suggestion. On a side note, has anyone released the infolayer for the animals yet. Searched the Google, saw some tuts, most were old, and only covered cows. All assumed that horses were 4, but I have not seen official confirmation of that yet. Any help would be appreciated. Thanks for your time!

Bilbo Beutlin (BBeutlin) 24.11.2019 12:10
To make an animal type appear in game, it must have a dedicated dealer. Some maps have different dealers for each animal type.
Search in i3d (text view) for "AnimalLoadingTrigger.onCreate". The related user attribute "animalTypes" determines which animals are traded.

Adam F Clark (afcbillsfan) 24.11.2019 13:37
That's not it, as they are already set to trade in the dealer. I can buy them, see money deducted for purchase, see the animals in the transport trailer, unload them at the pen thru the dialog screen, still no show. Removed all mods but map and horse pen, still no luck. Tried the horse pen on vanilla Ravenport, and a couple other mod maps, worked fine, horses showed ingame. It has to ne something to do with the map itself, but I can't fathom what that might be...

Bilbo Beutlin (BBeutlin) 24.11.2019 13:55
Are there any erros indicated in the game log?

Does the map have custom scripts?
Look into "modDesc.xml" for <extraSourceFiles> or a mission script deviated from <map .. filename="$dataS/scripts/missions/mission00.lua".

What about original (unmodded) version of the map? Is there working all fine?

Note: Log in to post. Create a new account here.