Community Forum

Adding Multi-terrain angles - issue

Forum Overview >> Farming Simulator 19

CategoryFarming Simulator 19
Created21.09.2020 17:40

Ross Baxter (Unknown) 21.09.2020 17:40

I am modding a map, trying to add multi terrain angles to No Mans Land. I have followed the wonderful video on YouTube by modelleicher, and I have used it before *on this map* and it worked perfectly. The map has since been updated but now it doesnt work?

I have followed the video to the letter, 3 times, but when I start a new game on that map, it just reverts back to the main screen. Nothing else comes up, the game doesnt crash.

How would I go about trying to figure out what is going wrong here? Is there anything on the game that I can bring up that might indicate?


Bilbo Beutlin (BBeutlin) 21.09.2020 21:23
I don't know this map, but if errors occur the first step should be looking into game log.

If the map has been changed, look into the update notes for further infos.

Ross Baxter (Unknown) 22.09.2020 11:34
Cool, so I have done that now. I started the game with development mode and when I try to start the map, when it quits back to the main screen the error is "cannot find nomansland.modmap?

I've checked the update log for the map, it only mentions fixing floating trees and adding in more placeables.

Bilbo Beutlin (BBeutlin) 22.09.2020 14:24
Check the modDesc entries <maps> <map ... for accordance with current setup. Probably there was changed something. Espec. heed 'id', 'className', 'filename'. Also check the LUA code in 'filename' for accuracy.

Ross Baxter (Unknown) 22.09.2020 17:41

This is the entry in the modDesc - <map id="ModMap" className="ModMap" filename="ModMap.lua" configFilename="maps/mapDE.xml"

The .lua file is called modMap.lua while the entries in the actual file are default, just 'ModMap'

Thanks for taking the time to help me out btw.

Bilbo Beutlin (BBeutlin) 22.09.2020 20:00
You're trying to load a savegame, right?
The error "cannot find nomansland.modmap" results from differences in the savegame's careerSavegame.xml <mapId>..
This mapId must match exactly the (case sensitive) ''
So either there were changes in the modDesc or you have renamed the map.
Simply start a new game/career and all should be fine.

Ross Baxter (Unknown) 23.09.2020 13:52
Ah yep, it was the name of the .lua, I had missed out a capital M.

Works now, thank you for all your help!

Note: Log in to post. Create a new account here.