Community Forum

GE crashes. "Transform group 'bush01' issue

Forum Overview >> Farming Simulator 19

CategoryFarming Simulator 19
Created23.11.2020 23:24

Yngve Bæsj (Unknown) 23.11.2020 23:24
I'm working on my first mod and have close to zero experience with scripting and debugging.

I've got an empty map with maybe 2 volumeTree.3id 2 default prefab houses, 1 small garage, 1 large silo and 1 johnDeere series6M.3id (Only used for scale when testing the map)- all are default prefabs from the main game. I have no mods installed other than the HOLMER DLC.

NOTE: I've tested the map while sculpting, and I've played the map to test it with the houses, garage and the tractor ingame. No issues.

Just now I were just sculpting the terrain and added a silo. I saved the map as usual, but I tried to launch the map with a new save without exiting the game. I don't know wether or not this is useful info.
The game crashed, and when I went in the editor again (which was open- with the map loaded), it froze and crashed. When I tried to launch the map again, It just keep crashing instantly. This is not an issue with e.g. default prefabs.

Here's the editor log:

GIANTS Engine Runtime 8.0.0 (23100) 64bit (Build Date: Nov 16 2020)
Copyright (c) 2008-2019, GIANTS Software GmbH (, All Rights Reserved.
Copyright (c) 2003-2019, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 8.2.2
Main System
CPU: Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz
Memory: 32683 MB
OS: Windows NT 10.0 64-bit
Physics System
Version: 5.9.5
Thread(s): 2
Audio System
Driver: SoftMixer WASAPI Stereo Headphones
Version: 2018.11
Frequency: 48000
Max. active sources: 256
Render System
Driver: OpenGL
Card Vendor: NVIDIA Corporation
Renderer: GeForce RTX 3080/PCIe/SSE2
Version: 4.5.0 NVIDIA 457.30
Shader Version: 4.50 NVIDIA
Max. Texture Layers: 16
GL_AMD_depth_clamp_separate not supported
Started 3 threads for threadpool 'Render threadpool'
Hardware Profile
Level: Very High (forced)
View Distance Factor: 1.300000
Shadow Quality: 2.000000 Base-Size: 2048 Filter-Size: 16 Shadow Focus Box true
Shader Quality: 3
Skip Mipmaps: 0
LOD Distance Factor: 1.300000
Terrain LOD Distance Factor: 2.000000
Terrain Normal Mapping: Yes
Foliage View Distance Factor: 1.600000
Volume Mesh Tessellation Factor: 0.750000
Tyre Tracks Segments Factor: 4.000000
Max. Number of Shadow Lights: 5
Max. Number of Lights: 512
Max. Number of Lights Per Cluster: 32
Bloom Quality: 5
SSAO Quality: 15
DOF: Enabled
Cloud Quality: 4
EnvMap Blending: Enabled
C:\Users\Yngve\Documents\My Games\FarmingSimulator2019\mods\Fosnes\maps\map.i3d (757.87 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/wheat.i3d (8.61 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/grassDense.i3d (3.29 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/canola.i3d (6.21 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/barley.i3d (4.84 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/maize.i3d (11.84 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/decoFoliage.i3d (31.41 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/potato.i3d (6.96 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/potatoHaulm.i3d (1.55 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/sugarbeet.i3d (5.19 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/sugarbeetHaulm.i3d (1.31 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/sunflower.i3d (9.20 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/soybean.i3d (7.43 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/oilseedRadish.i3d (1.95 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/poplar.i3d (8.34 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/bush01.i3d (14.11 ms)
Info: transform group 'bush01' has elements very far out from the cell edge (29.61% expansion)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/oat.i3d (9.69 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/sugarCane.i3d (7.88 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/sugarCaneHaulm.i3d (1.19 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/cotton.i3d (7.09 ms)
C:/Users/Yngve/Documents/My Games/FarmingSimulator2019/mods/Fosnes/maps/foliage/weed.i3d (14.39 ms)
Check for updates (

I want to do my best saving this map, and I will go a long way to fix it. Is that even possible? I've read multiple people are stating this is an fix only the people behind GIANTS can do. If that is the case, then what can I do to avoid this if I have to start over?

PLEASE ALSO NOTE: I've tried moving the foliage and shader folders to my map folder. If I overwrite existing files, I get more errors.

Bilbo Beutlin (BBeutlin) 23.11.2020 23:57
The issue about "transform group 'bush01' .." you can simply ignore. It's just an info and it doesn't affect gameplay.

I'd assume your problems are caused by using cloud storage (OneDrive or similar). Don't use such for FS related files. Disable cloud synchronization of your user folder "documents" or switch off cloud storage at all.

If you are working directly on mods in the game's modfolder, it is recommanded to move the modfolder to a neutral location, not supervised by Windows UAC/DEP or any antivirus programs. Then change in your "gameSettings.xml" <modsDirectoryOverride active="true" directory=".."/> where you insert the new path.
Also pay attention that you don't have the mod/map twice in modfolder (zipped and unzipped).

Yngve Bæsj (Unknown) 24.11.2020 08:34
Hi Bilbo and thank you for replying

I am not using any cloudbased storage, as I have even deleted it from my PC.
I've moved the entire mods folder to another diskdrive, overrided the path and directed the directory to it's location with no luck.
And there is only 1 map in my modfolder. Not zipped.

I am using Kaspersky Internet Security for antivirus. I do not know of any neutral locations I could otherwise place my folder to avoid supervision by the program. Are you suggesting external storage devices? I've tried that as well.

Bilbo Beutlin (BBeutlin) 24.11.2020 14:26
External storage devices are not recommanded since in general slower than local drives.
Make sure, the folder you're working on is in the antivirus exception list (white list).

Unluckily the log doesn't indicate a dedicated error. So you should roll back to an earlier backup (what you have made hopefully). Since the error appeared after you have inserted a silo, this is probably the causer. Game functional objects should not be added in the map directly, but inserted by the defaultItems only.

Yngve Bæsj (Unknown) 24.11.2020 17:39
Hi again,

I've whitelisted the folder, and rolling back did not work either. I have no idea what's going on. It's like the map.3id file were corrupted or something.

I started from cratch and imported textures and heightmap to my new save. Heightmap didn't work but at least the painted textures did.

I still have the dm files for heightmap. How do I use them on a new file other than manually moving them to my new map folder?
Only thing I find on Google regarding heightmap imports are related to FS17 and/or Google Earth techniques.

Bilbo Beutlin (BBeutlin) 24.11.2020 17:56
Are you sure you have a compatible heightmap? This is a PNG file in gray scale and must fit properly to the map dimensions. The exact filename you get in map.i3d <TerrainTransformGroup name="terrain" .. heightMapId="..". This ID refers to <File fileId=".." where you get the filename.

Did you edit it perhaps in a paint program? This may cause failures by wrong export format or the program's optimization features.

Yngve Bæsj (Unknown) 24.11.2020 18:46
Yes, the heightmap were edited in GE using the same empty map as the new map. No other programs have been used.
I simply replaced the flat/empty new heightmap with the new one as both had the same name, so I can't grasp why it shouldn't be compatible.

I don't have the log for this anymore, but while doing it, the log stated something had to be converted from a number to another, and the log stated it did this itself.

Nevertheless, I conclude my issues as solved as of now.
Thank you so much for your time!

Note: Log in to post. Create a new account here.