Community Forum

Combine with mouse control wont work?

Forum Overview >> Farming Simulator 19

CategoryFarming Simulator 19
Created09.01.2021 00:33

Jonas Graulund Hansen (Traktorjonas) 09.01.2021 00:33
Hello out there, I've tried making my combines be able to move the feeder up and down with mouse, also with cutter on it. And about a year ago i had it working on 5 combines i made, really simple - But now it wont work, It says this in the log file

Warning (C:/Users/Bruger/Documents/My Games/FarmingSimulator2019/mods/FS19_IdealExtension/xml/IDEAL9.xml): ControlGroup '1' not defined for 'vehicle.cylindered.movingTools.movingTool(0)'!

What do i need to add and where for this to work now? I guess its the updates that fucked something up?

Bilbo Beutlin (BBeutlin) 09.01.2021 09:16
Obviously you have a <movingTool> with <controls groupIndex=.. where this index is not defined in <movingTools> <controlGroups>.

See in default vehicles how to setup <controlGroups>.

Jonas Graulund Hansen (Traktorjonas) 09.01.2021 14:49
I have found that now.. thanks

However now i stand with a new problem - Whenever i use mouse control ingame the header does not follow up and down...
I have added <inputAttacherJoint value="true" />
But maybe this is Outdated? It doesnt seem like there is no errors regarting this in the lag?

Bilbo Beutlin (BBeutlin) 09.01.2021 17:57
I don't know what you have done at all.
But this tag <inputAttacherJoint value="true" /> is complete nonsense.

For mouse controlled attachers should be used <attacherJointControl>. There are several default vehicles with this feature. Search in $data/vehicles for this tag. It's very easy with the Notepad++ "search in files".

Jonas Graulund Hansen (Traktorjonas) 10.01.2021 04:30
Ok, Well - <inputAttacherJoint value="true" /> - i've used back over a year ago also in combines, and it worked well at that point, but now i does not?

Also i only find Chainsaws and other wood implements - I dont see how i can use them, i dont think thats right... I can make a video purhaps and show u, what i mean.. Thank you for your aid tho :D

Bilbo Beutlin (BBeutlin) 10.01.2021 12:39
The attribute <inputAttacherJoint value="true" /> doesn't exist, also in earlier FS.
The only thing relating attachers was <inputAttacherJoint .. forceSelectionOnAttach="true|false" .

Jonas Graulund Hansen (Traktorjonas) 10.01.2021 13:59
It is on Slurrytankers with drawbar which can go up and down.... Also augor trailers and other tippers... but nvm :D ill try make a vid at some point so i can show u, then u might now just what to do? :D

Bilbo Beutlin (BBeutlin) 10.01.2021 14:32
Ah .. now I see what you mean. This is not part of <inputAttacherJoints> but <movingTools>.
There the <movingTool> <inputAttacherJoint value="true" /> determines this movingTool has an attacher node which has to be moved together with the tool. There were no changes, this works still as usual.
However it will not work if you have a tool attached with automatic height adjustment <inputAttacherJoint> <heightNode>

Jonas Graulund Hansen (Traktorjonas) 10.01.2021 18:29
Like if the header follows the ground?

Bilbo Beutlin (BBeutlin) 10.01.2021 20:06
Exactly. And this <heightNode> has priority against a manual control.

Jonas Graulund Hansen (Traktorjonas) 12.01.2021 14:10
But its weird i think, cause i had it working on 5 different combines a year ago with 4 different headers... also one of which im trying to use now?

Bilbo Beutlin (BBeutlin) 12.01.2021 15:14
Probably the tools you have used got updated and have this heightNode now.
If it's such a problem for you then take out the heightNode in xml. For default vehicles make "new mod from game" at first (in Giants editor). Or, if you don't intend to change the i3d, you need only the vehicle.xml and a new modDesc.xml.

Jonas Graulund Hansen (Traktorjonas) 14.01.2021 17:46
Sadly does not work either - But its weird, they brooke their own items, such as NH and Case combine which can tilt the end part of the pipe does not work anymore - They changed something... I tried taking out the heightnode but did not work.

Jonas Graulund Hansen (Traktorjonas) 14.01.2021 18:26

Bilbo Beutlin (BBeutlin) 14.01.2021 20:38
>> NH and Case combine which can tilt the end part of the pipe does not work anymore
Here it works as usual.
So I would rather assume you have problems with the key/mouse assignments.
Did you check the game log for warnings relating key bindings?

Perhaps move your current "inputBinding.xml" to another place for backup.
Then try without "inputBinding.xml" so the game can create a new default one.

There may be also conflicting mods with same key bindings.

You know the first rules for irregular behaviour?
1. Check the game log
2. Take out all mods except the one you're testing.
3. Check the game log

Jonas Graulund Hansen (Traktorjonas) 14.01.2021 21:10
Bilbo Thank you for keep helping me -
Right at this moment they are my only mods in folder, and there is no errors or warnings regarting the Ideal or the header

However Im not sure what u mean with the key mouse assignments

The feeder on the combine moves up and down as is should, but the real problem now is, that the attachment (The header) do not follow up and down with it?

Bilbo Beutlin (BBeutlin) 14.01.2021 23:02
Try the step with the "inputBinding.xml" I've described above. So we can exclude possible key binding failures.

Check the combine-header attacher, compare xml attributes with a similar default vehicle. Same with your <movingTools> entries.

Look into the FS patch notes (ModHub -> Updates) whether you can possibly guess if a certain point might have touched your affair.

Sorry, but at the mom I've no idea what could have caused malfunction after a certain game update.
At least here I could not notice changes relating such affairs.

Note: Log in to post. Create a new account here.