Community Forum

green wire vs black wire blender giants editor and more

Forum Overview >> Farming Simulator 19

CategoryFarming Simulator 19
Created12.01.2021 17:04

Fuman 12.01.2021 17:04
Here's the story:

I wanted to remove the rear hitch from a truck. Normally, I would load it into Giants Editor (GE) and simply select/delete, then update the corresponding xml to reflect the changes.

However, this particular hitch has a transform "near" it to represent the attach function, but the hitch itself is part of the model/mesh. So yesterday I started on the journey of modify fs19 assets in Blender.

1.. download, install blender (blender website)
2. download, install the i3D exporter plugin (vertxdezign website)
3. create/export .object file of the asset using GE (in my case, the asset is just the truck frame transform)
4. import said .object into blender
5. modify the asset (cut the hitch of the truck)
6. rescale the asset in asset properties, then ctrl+A and choose scale (.909 worked for me in properties)
7. export the asset as an i3D file
8. open original truck in GE, offsets to 0, import the asset modified in blender (the truck frame)(for me, was a perfect overlay)
9. reorder transforms while maintaining relationships (i.e, make sure old frame children and attribute are transferred to the new frame, then delete the old frame)
10. Done

However, once I was done I started clicking through the transforms to make sure everything was kosher, and I briefly saw "the hitch".
"wtf",, I said.

It turns out that for this particular truck, the author (who did an amazing job on it) had created the "green wire frame" of the trucks frame , which shows up as a purple base object transform in the scene graph navigation window, and then overlaid it with a three-part "black wire frame" of the trucks frame, additional goodies included with it...

So it is the last "3rd" of this "black wire frame" that has the hitch on it.... even though I removed the hitch from the "green wire frame" the hitch is still going to show.
And, when I select the transform for the black wire frame section that contains the hitch (note it is a basic transform, and not the purple kind), I can move it about, but it stays attached to the other two sections of the black wire frame.
If I try to delete the transform, it just curls up like a dead spider and hangs around.... just to freak people out I suppose.

And lastly, I have yet to find a way to follow the 10 step process that I outlined earlier that will allow me to modify this black wire frame...
It seems as if you can only make objects of the purple parents in the scene graph navigation window, and not the base/generic transforms...
Hence, no object can be created of this 3-part black wire frame....

Is this something that is locked away, unchangeable, a "one-off" creation ?
If so, then I can just add the functionality I want to the hitch as is, but it will look like a baboons ass in game.
If not, then could someone pass on any tips or advice please?

[edit] first resource has been found: ""

Thank you gentlemen.... um, and ladies

Fuman 12.01.2021 19:54
No luck with the resources I've tried so far....
One thing I did notice however, is that one fellow in a video was able to select an asset in Giants Editor, then export selected item as an object file, and then when he imported and opened it in Blender, not only was the selection there, but also all of the transforms that were a part of that selection.
For whatever reason, I can't seem to get the same behavior. Only the selected item gets exported/imported.. the children transforms of that selection are never included.....

Thoughts ?


Fuman 12.01.2021 20:30
I figured it out... kind of.

The black wire mesh isn't in fact, a black wire mesh... it is an image file ( .dds ) that gets painted over the green wire mesh!

So in essence, by removing the hitch from the wire green frame, I have cut and removed a slice of cake, but have left the icing intact!
It is painting a hitch over empty space!

Now, the question is born anew for this thread, albeit more direct and concise.... how do I remove the icing after removing the slice of cake?

p.s, now I can't stop thinking about cake.... stupid analogy.

[edit] and in defense of my ignorance, please note that everything I am working with is in Ukrainian.... as such, you will delighted to hear that Ukrainian for "Frame" is "Rama"... cool stuff huh?


Bilbo Beutlin (BBeutlin) 12.01.2021 20:47
Well, I can't say much about 3D modeler handling.
But why do you use in GE the wireframe display? Switch to "shaded" and you'll have less problems.

Fuman 12.01.2021 22:34
Well I am new at this, but I have found that using both wired and shaded helps me to develop a better mental image of the part I am currently messing up.

As for the problem at hand, I have found the image that is used in Giants Editor to paint this particular part of the model. It is used as the "gloss map".

However, when I open said file in Paint.Net (it's the only tool I have), it looks like hammered dog poo. Just a bunch of neon green squiggles on a black background...

But I am certain that somewhere in that image is buried the hitch that I want to remove....

Any tips would sure be welcome right now...


Note: Log in to post. Create a new account here.