Community Forum

Strange train problem

Forum Overview >> Farming Simulator 19

CategoryFarming Simulator 19
Created06.07.2021 09:38

Tommy Aleksandersen (WolfBoy) 06.07.2021 09:38
Hi, Like the title say, I have since yesterday run into a strange problem. I have set up a new train system on my map and I got it to work, this is a train from Felsbrun but the tracks is from internet. train track constructon set. Okay. I set up the tracks and made a spline. tested the system and it`s up and running. But the huge problem is. The wheels on the train is sideways on the track, the locomotiv and the wagons.

If I i make a spline and set it outside the track, just right on a field the train is normal. I tought maby my spline is broken or something so I made a new spline for my track. The same thing happend again, The wheels are sideways on the track. the spline is set just abowe the boards on the track.

Can it be the track that is broken or something?

Bilbo Beutlin (BBeutlin) 06.07.2021 19:39
Often this comes if the spline has a rotation.
An spline must not have a rotation or scaling.

Tommy Aleksandersen (WolfBoy) 08.07.2021 05:03
I almost giving up this train shit now. I will try to explain as good as I can. When it come to the rotation and scaling of the splines I can`t see how that would be the problem, becaouse you can`t change that when you lay down the spline, the only way to dot hat is to change the attributes. And why would i do that, i don`t see the point. The scaling is also set to out greyed so can`t change it. it`s auto set to 1 on x y and z.

The track is only visual so we can forget that part.

1: I took the old spline out of the track and tested, the same train issue.
2: I made a new spline on the track, this time with extra caution but still the same train issue.
3 moved the new spline out of the track, still the same train issue.
4. Made a new spline, this time outside the track on a flat surface. This time it went good. The train is normal.

So my question now is, is it because of the up and down hills? You see, i have some small mountens on my map and i wanted the train to go between them, and there is a up hill and down hill and some turns. when it comes down from the mountens there is a flat terreain.

My conclusion on this that you can`t have train to go this way. it`s need to set on flat terrain. My test conclude this thinking because my splines are okay. If I think of it, I can`t remember a map with trains going up in mounten side ether.

if you now how to fix this please let me know or any ideas is also great.

Thank you Bilbo for helping

Bilbo Beutlin (BBeutlin) 08.07.2021 05:43
Hills and mountains don't matter. Look at the default maps. Ravenport has many hills in the train route, Felsbrunn even high mountains.

What you describe looks like you have embedded the train directly into map?
If so: that's wrong. Since FS19 the trainSystem must have its own custom i3d and xml. It is inserted by the defaultItems. After you have created the train spline on map, export it and delete it from map. Then create the appropriate xml and add it in "defaultItems.xml" accordingly.

Tommy Aleksandersen (WolfBoy) 08.07.2021 07:42
I know, i done that you describe. it`s acting as a placeable.

I importet the trainSystem from felsbrun. deleted the spline, made a new spline for my track, then saved.
i then exported the trainSystem from my map into my own placeable folder. I deleted the trainSystem that I exported from felsbun and saved my map again. And then. I copyed the xml file from instalation folder and into my own trainSystem folder.
Nothing much to do here exept from change the path to my own iD3 file. I did not need to change any of the node numbers, they was the same.

I then copyed the item line from item.xml in the instalation folder and past into my own item.xml file. changed the path and that is all to it.

Like I was say, the train system works on flat land but not in the hills for some reason.

Yes I know there are hills there but, well, this is very strange.

Bilbo Beutlin (BBeutlin) 08.07.2021 10:40
Is there perhaps accidently a rotation in the "defaultItems.xml" for the trainSystem?

Else I can only guess it's reasoned by the used "train track constructon set". Maybe it uses rigid body (collisions) a little higher than usual. You could try to enlargen the <spline splineYOffset (in trainSystem.xml).

Note: Log in to post. Create a new account here.