Community Forum

game will not load placeables

Forum Overview >> Farming Simulator 19

CategoryFarming Simulator 19
Created12.08.2021 17:56

Bo Lövgren (Bossel57) 12.08.2021 17:56
I think I'm going crazy. Are a first time map maker that is trying to learn how it is made and I've learned a lot, but one thing is not going as it should.
I'm trying to get the game to load placeables at startup and I succeeded a couple of times, but now nothing will load (placeables).

I discovered a phenomenon that I don't understand. This is my defaultItems.xml:

<?xml version="1.0" encoding="utf-8" standalone="no" ?>
<item className="FarmhousePlaceable" filename="$mapdir$/placeables/woodenHouse.xml" position="-50.65 58.26 310.08" rotation="0 0 0" defaultFarmProperty="true" farmId="1" />


and this is what log.txt says:

2021-08-12 17:28 Error: i3d 'C:/Users/bosse.DP/Documents/My Games/FarmingSimulator2019/mods/FirstMap/woodenHouse.i3d' could not be found.
2021-08-12 17:28 Error: failed to load i3d file 'C:/Users/bosse.DP/Documents/My Games/FarmingSimulator2019/mods/FirstMap/woodenHouse.i3d'
2021-08-12 17:28 Warning: corrupt savegame, item 1 with className FarmhousePlaceable could not be loaded

In other words the game skips the folder "placeables" when it's trying to load the woodenHouse.i3d file. The xml file is located in the same folder and it reads that, so why does it not read the i3d file from the correct folder?

Do anybody have a theory of what I've done wrong. I've tried on other maps and it is the same result. It works a couple of times, then this happens. Woodenhouse is the only object I succeeded to load.

Bilbo Beutlin (BBeutlin) 12.08.2021 20:17
You must setup the right path in the xml relative to the mod's root folder:

Bo Lövgren (Bossel57) 12.08.2021 21:53
Tanks Bilbo! I knew I was missing something. Now it works with all placebles.

Note: Log in to post. Create a new account here.