Community Forum

Train System

Forum Overview >> Farming Simulator 19

CategoryFarming Simulator 19
Created19.12.2021 22:43

Ed Propsner (crotchfrog) 19.12.2021 22:43
I'm trying to get my train system up and running and it keeps giving me this error: Unable to find spline for traffic blocker (placeable.trainSystem.railroadCrossings.railroadCrossing(2).trafficBlockers.trafficBlocker(0)) at -1565.2 115.5 -431.2. What spline is it referring to? The actual railroad spline is the only spline I'm aware of. The coordinates it lists are way up in the air nowhere near the railroad itself. I scoured the train system and can't find anything that is pointing toward those coordinates. Is anyone familiar enough with this to point me in the right direction? It's obvious that I'm overlooking something. As with any of my errors, I'm well aware that I am the reason it no longer works as it should :)

William Rowe (Bonger76) 21.12.2021 04:30
In the trainSystem.xml you need to block or remove the trafficBlockers.I block it because in the future might use it .
It is thier for if a spline goes through the railroadCrossing to help controll traffic in notepad++ if you whant to leave something in a.xml
and not have the game read it put this at the front <!-- and this at the end --> see below

<railroadCrossing rootNode="0>5">
<activation startDistance="200" endDistance="200" />
<gate node="0>5|0|0" startRot="0 0 0" endRot="90 0 0" duration="4" closingOffset="2" />
<gate node="0>5|1|0" startRot="0 0 0" endRot="90 0 0" duration="4" closingOffset="2"/>

<trafficBlocker node="0>5|0|1" />
<trafficBlocker node="0>5|1|1" />

<signal node="0>5|0|2|0" alternatingLights="true" />
<signal node="0>5|1|2|0" alternatingLights="true" />
<crossing template="TRAIN_CROSSING_BELL_01" linkNode="0>5" />

Ed Propsner (crotchfrog) 21.12.2021 11:41
HaHa, I swear sometimes that I should be wearing a sign warning other people that I'm prone to fits of stupidity!! It never donned on me that the spline it was looking for was the traffic spline in the event AI traffic would travel through. I feel like a real jackwad over that one! I was so focused on the railroad spline. The train comes, arm comes down, and we're good to go. I haven't tested it yet, but I don't suspect I need to. I'm sure it's going to work just fine once I comment out the blockers that don't have traffic splines running through them.

Is there a reason I can't drive the train? At this point I'm able to call the train but can't drive it once it stops. I haven't worried too much about it because the train system is not complete, and I haven't really looked into the issue. I figure there is probably a good reason and I'll look into once I get that far. I would like to drive it though to see if there are any adjustments that need to be made to the tracks or surroundings.

William Rowe (Bonger76) 22.12.2021 05:47
Not being able to drive it,if you mean you cant enter standing next to it ,it could be the power tool mod if you are using it,it happend to me rented
the train got out to look at something whent into flight mode and then could not reenter the train I had to go to the map and enter that way,it did the same to vehicles could only enter through tabing.

in your train.xml you need to block this -- <!--<drivingRange startNode="1|0" endNode="1|1" sellingStationId="sellingStationTrain"/>-->
those node stop the train and might block use,when you block this the train doesn't stop it will keep going around the map ontill you hire it.

Ed Propsner (crotchfrog) 22.12.2021 16:32
<drivingRange startNode="1|0" endNode="1|1" sellingStationId="sellingStationTrain"/> Yep, this was the problem. The reason I didn't try to comment it out in the first place is because I changed it up a bit and tried to have it serve a different function. It worked, but not very useful if you couldn't actually drive the train.

Bootsy B (bootsy) 02.01.2022 19:32
Hi, i remain with the same problem ... if i block the DrivingRange like you say, it work, but u stay in the train oustide the map its not the point ;) ... I dont understand what i do wrong. If i dont block, i cant go in the train, but i guess i would be kick of the train ... and the rest work fine ...

William Rowe (Bonger76) 02.01.2022 23:46
@Bootsy ,The train system I have is completly on the map It does not leave the map,if you block the DrivingRange you are going to have problems,if the train leaves the map ,thier is still a boarder collision on the map.

Bootsy B (bootsy) 03.01.2022 00:35
what im expecting, is the train leave the map for another town (sell point), all is set ... i see the town in the minimap, on the sell point too, all look fine... that's why i put the DrivingRange ... but i cant go in the train ... i just can rent it. I Did exactly same then the original map ... i dunno ...

William Rowe (Bonger76) 09.01.2022 03:33
I had a problem getting in the train when using the power tool flymod.

Gerhard Pucher (Gerhard77) 14.02.2022 22:27
Hi. Did you solve the problem? The beginning and end of the spline must be outside the map if the driving range is used confusingly and the beginning and end points of the spline must not be on top of each other but slightly separated. drivingRange must become law at the end and beginning of the map. Everything works. However, when I get to the end of the map with the train, I am thrown off the train as planned and asked if I want to sell the goods. Unfortunately, the name of the point of sale is not there, just UNKNOWN. No matter what I do. No error in the log, no information what is wrong. The train does not sell the goods. Does anyone have a solution for this?

Note: Log in to post. Create a new account here.