Community Forum

Fs22 Failed to open modDesc.xml

Forum Overview >> Farming Simulator 22

CategoryFarming Simulator 22
Created24.01.2022 19:37

Tony Tomaic (Stxor) 24.01.2022 19:37
Hello guys im new to moding world i added forestry grill to zetor crystal hd . when i zip my mod and add it to mods folder it dosent works but when its unziped just a regular folder it works ,
LOG.txt Shows when zipped
Error: Failed to open xml file 'C:/Users/Tony/Documents/My Games/FarmingSimulator2022/mods/CRYSTAL_HD/modDesc.xml'.

Fox Doyle (FoxNextDoor) 24.01.2022 20:02
So, it works in just a regular folder? You can see your mod in game without it having to be zipped, correct?

Make sure your modDesc is version 62, then zip it, slap it into your mods folder, call it a day.

If it still shows it is unable to read modDesc, then you could try a different description, or use a modDesc from another mod, just rename and make sure the path for your CRYSTAL_HD (.xml) is correctly formatted.

Tony Tomaic (Stxor) 24.01.2022 22:57
<?xml version="1.0" encoding="utf-8" standalone="no" ?>
<modDesc descVersion="62">
<en>Zetor Forestry</en>
<![CDATA[Zetor Forestry ,
the right tractor for large logs that take up a lot of the power.
Whether in Europe or the American countries, you can always count on him.

<multiplayer supported="true" />

<storeItem xmlFilename="crystal.xml"/>

Hey thanks for your reply i tried version 62 and 63 (current game version) . i tried diferent descriptions but it still didnt work , only shows my mod in game when is in mods as regular folder , once i zip it and remove regular folder from mods and leave zip folder inside it dosent shows in game . still same error in log.txt
Error: Failed to open xml file 'C:/Users/Tony/Documents/My Games/FarmingSimulator2022/mods/CRYSTAL_HD/modDesc.xml
link to my mod :

Ed Propsner (crotchfrog) 25.01.2022 14:17
Hey Tony. The mod seems to be in order, no issues. It loads just fine for me and the log is error free. I was able to purchase and drive it with no issues.

It looks like a filepath issue. The game is looking to CRYSTAL_HD for the modDesc, but the mod itself is contained within It looks like you are still referencing that directory somewhere. You have completely removed CRYSTAL_HD from your mods folder leaving just the zip file?

Tony Tomaic (Stxor) 26.01.2022 09:25
I found out by myself where i made mistake , it was made during the zipping process, i zipped the folder which is wrong , once i entered the folder and selected all the files whitin folder and then zipped it , its working with no problem , i know stupid mistake hope ot helps someone hehe

Note: Log in to post. Create a new account here.