Community Forum

TrainSystem issues

Forum Overview >> Farming Simulator 22

CategoryFarming Simulator 22
Created05.03.2022 01:56

Adrian Droste (oggimaster) 05.03.2022 01:56
Hello there,

I've got the trainSystem with one active train running on my 4x modmap. I have following issues which might are a bugs. Eventually you can help.

1. The entry in the placeable.xml has to be translation="0 x 0". So I have to put my trainSystem on another height than 0, otherwise it doesnt work.

2. The height of the spawned in object types are different to the placed ones: The train levitates 60 units above the spline, the railroadCaller 20 units and the barriers with lights and sound 30 units high. It is completly strange. This issue makes precise positioning very difficult.

3. The train visually glitches out at the border of the map. I also placed start- and endnode there. Maybe this issue is connected to the 13 wagons I've attached to the train. This issues is not as urgent as the others.

Ed Propsner (crotchfrog) 05.03.2022 14:42
When you say that you have to put your train system on another height other than zero or it doesn't work, it does not work how? Throws an error or just does not show up? If you mean you have the to change the value to a non-zero number in placeables.xml, My guess would be that this is why your items are all over the place, it's the difference between zero and your value in the placeables.xml. Keep the placeables entry at 0,0 and we'll try to figure out why that's not working for you.

Just out of curiosity, in your trainSystem.xml, what value do you have for splineYOffset?
<rent pricePerHour="1000"/>
<spline node="0" splineYOffset="0.155" />

Adrian Droste (oggimaster) 05.03.2022 18:56
Thanks for your response.

If the trainSystem in the placeable.xml is at "0 0 0" it doesnt show up on the map, neither gives errors in the console. It is like I never implemented it. As you are saying, it is likely that the second issue correlates with the first one.

My splineYOffset is standard:

<rent pricePerHour="1000"/>
<spline node="0" splineYOffset="0.155" />

I will test it once again in a moment if it works now. The weird thing is, that the first successful implementation of the train worked at the fifth try without changing something but the height.

Adrian Droste (oggimaster) 05.03.2022 20:01
As Todd Howard once said: "It just works". I really dont why it works now. Both issues solved at once. The visual glitch isnt so important. Maybe it disappears when I modify the spline for the final version of the map - then it doesnt glitch or you cant see it.

Colin Smith (WrinkleysRule) 05.03.2022 20:17
Visual glitch possibly clipDistance

Note: Log in to post. Create a new account here.