Community Forum

Map wont load after removing trees

Forum Overview >> Farming Simulator 22

CategoryFarming Simulator 22
Created07.03.2022 20:53

Phil Marshall (FlyingBadger) 07.03.2022 20:53
Hi there

I am currently looking at starting a game on a modded map, The Construction Map, I am wanting to remove a few trees from between fields and also remove the barn and the garage as these are in the way.

I have removed what i want to in the editor but once saved the map will no longer show up as an option when i start the game, if I revert the changes and go back to the original file the map loads up no problem.

I need to use the editor for the barn as when I delete it via the lanscaping demolish button it leaves some concrete behind and leaves me with 2 holes that I can not filll in.

Am i missing something, as all the tutorials say to just delete the things you dont want in the editor, save the file, zip it back up and all will be fine minus the removed items.

Thanks in advance for any advice

Ed Propsner (crotchfrog) 07.03.2022 22:46
Either not deleted correctly which is kind of hard to mess up, or not zipped back up correctly? Anything showing up in your error log?

Try not zipping it up again, and instead put the whole folder into your mods folder the way that it is. If it loads up and runs, it's a problem with the zip, if not, there was an issue with the deletion. Still, check the log and see if it gives you a heads up about anything.

Phil Marshall (FlyingBadger) 08.03.2022 14:02
Hi crotchfrog, thanks for your reply.

I have tried deleting 2 ways, first way clicking on the item I want to delete and then just pressing the delete key, second way clicking on the item, going to edit and then delete, I have tried just deleting one tree at a time and also selecting all the trees I want to delete and deleting as a whole, buildings have been deleted one at a time.

I am currently using 7Zip so will try winrar, as this seems to be the go to software on the tutorials and i will try with the folder unzipped.

I have checked the log file and no errors are showing at this time.

I will report back after trying the couple of things mentioned.

Thanks once again


Phil Marshall (FlyingBadger) 08.03.2022 14:36

So i tried using Winrar and got the same result, only deleting one tree, saving and then zipping back up, map wont load, when I checked the log file it showed all my other mods in the folder but didnt even show the map that was actualy in the folder.

I then tried putting the unzipped map folder in my mods folder and everything works absolutely fine, map modded as I like and all loading as it should.

Thanks once again crotchfrog for you advice, I really wouldnt have thought to try an unzipped folder as I assumed they would only work when zipped.



Ed Propsner (crotchfrog) 08.03.2022 15:38
Keep in mind that any unzipped mods will not work in multiplayer, and you can't upload to any sites or anything that way. It does however let you know that the problem is HOW it is being zipped, not the program that is doing the zipping. Grab any other working mod map and look at how they have their zip set up and try to replicate what they did. The most common error I see is people throwing the entire folder into the zip when it's actually the contents of the folder that belong in there.

Glad you're getting it all sorted out!

Phil Marshall (FlyingBadger) 08.03.2022 17:42
Thanks crotchfrog

So it would seem the original map goes: FS22_Construction_Map ZIP FOLDER - FS22_Construction_Map FOLDER (Data inside this folder)
All the other mods I have looked at seem to be: FS22_Calmsden ZIP FOLDER - (Data inside this folder)

So I will have a play about with additional folders etc. and see if that works for the zipped folder.


Ed Propsner (crotchfrog) 08.03.2022 18:37
Without seeing it, my guess would be that you need to zip the contents of FS22_Construction_Map FOLDER, but not the folder itself. Open that folder up, select everything inside of it, and send to/add to zip, or whatever the process is for the zip utility you are using. That should do the trick. FS22_Construction_Map FOLDER was created when you unzipped the map and was never part of the original map or zip. It's what's inside of that folder that you want zipped. You don't have to change a thing. Just open, select all, zip.

Note: Log in to post. Create a new account here.