Community Forum

_weight files

Forum Overview >> Farming Simulator 22

CategoryFarming Simulator 22
Created29.03.2022 21:56

Bartson Fggse (bartson) 29.03.2022 21:56
Hello, did anyone have such a problem that when painting with textures on the map and saving the map, after exiting and reloading the map, the painted textures were not saved? As if the editor would not affect the weight files. Someone knows how to fix it?

Ed Propsner (crotchfrog) 30.03.2022 04:30
Check your map.i3d and make sure the file path for "whatever_weight.png" is pointing toward your local copy of the files and not your game copy or some other location. Did you check the error log?

Bartson Fggse (bartson) 30.03.2022 08:51
The lines in the file point to valid local files, the log shows nothing. When I run the original map in ge, it is all covered with animalMud texture, it is also somehow related to my problem

Ed Propsner (crotchfrog) 30.03.2022 12:55
Is this a map you just started? Did you copy the _weights from base game or make them yourself? Did you scale them up from a smaller size? You're seeing animal mud because it's the first texture in the list, and it seems as though GE is having an issue reading your weights as well as writing to them (or they are all blank). Verify that you are able to read/write to the data folder where the weights are stored. Also verify that your _weight files are grayscale 8 bit png. If you scaled them from a smaller size it could be there was an issue with how the image was resampled when enlarging? I'm honestly throwing out guesses until we have a reason to lean in any one direction. Not to mention it's early here and my thought process is a bit fuzzy ... need coffee!

Bartson Fggse (bartson) 30.03.2022 18:02
I don't write these textures on every map. I created my clean map with new mod from game and even there the weights textures were not created. The basic French map from the game when I start it in ge is textured painted alpine map also the problem is only on the American
The editor does not want to overwrite these textures at all costs

Colin Smith (WrinkleysRule) 30.03.2022 19:33
Firstly, what GE version are you using and secondly how are you saving the map after painting texture, by selecting an icon or File SaveAs

Bartson Fggse (bartson) 30.03.2022 19:42
The editor's version is the latest. I save Ctrl + s but I tried to overwrite the file with save as and it did nothing

Colin Smith (WrinkleysRule) 30.03.2022 20:06
So just to confirm what you are doing

You are creating a newmod from Game choosing File --New Mod from Game -- Mod_Map_Us

A working Directory prompt then appears giving a default path as C:/Users/YourComputerName/Documents/My FS 22 Mods/Mod_Map_US --Have you changed this path at all ??

Which puts your new mapUS mod in Documents/My FS 22 Mods folder

Paint new texture and save with Ctrl-S and when reopening map from its new folder C:/Users/YourComputerName/Documents/My FS 22 Mods/Mod_Map_US/maps/mapUS--map.i3d you do not have the new texture showing.

Bartson Fggse (bartson) 30.03.2022 20:08
Yes, everything is correct

Colin Smith (WrinkleysRule) 30.03.2022 20:57
Ok, any errors in the editor_log.txt??

You said previously--"The basic French map from the game when I start it in ge is textured painted alpine map also the problem is only on the American"

Does this mean that when you open the maps directly from the Farming Simulator 2022 game folder --data/maps / mapAlpne, mapFR they show as textured but the mapUS map does not, in which case does the mapUS open correctly in game.

Also this "I don't write these textures on every map. I created my clean map with new mod from game " how do you create your 'clean map' using the new mod from game as my previous post or do you put different clean weight files in it.

Bartson Fggse (bartson) 30.03.2022 21:05
There is nothing in editor_log

I have already solved the problem with displaying the texture on the American map

The map was created with the new mod from game option and then cleaned and painted with grass texture by another person

Colin Smith (WrinkleysRule) 31.03.2022 11:50
From your previous posts regarding the problems with painting and the map being covered with the animalMud texture (grass texture ?), it would appear that this 'other person' did not clean the map correctly.

You have previously said "The lines in the file point to valid local files"

Have you checked they match with the Layer values, for example

<File fileId="4" filename="$data/maps/mapUS/data/animalMud01_weight.png"/>--------weightMapId="4"
<File fileId="5" filename="$data/maps/mapUS/textures/terrain/animalMud01_diffuse.png"/>------------detailMapId="5"
<File fileId="6" filename="$data/maps/mapUS/textures/terrain/animalMud01_normal.png"/>----------normalMapId="6

<Layer name="animalMud01" detailMapId="5" normalMapId="6" unitSize="2" unitOffsetU="0" unitOffsetV="0" weightMapId="4" blendContrast="0.2" attributes="0.043 0.029 0.02 1 1 8"/>

If so then all I can suggest is you start from scratch and create your own clean map without relying on the other person

Bartson Fggse (bartson) 31.03.2022 17:04
The reason must be different because the editor does not overwrite these textures even on other maps of other modders, for example with modhub
And those IDs match

Colin Smith (WrinkleysRule) 31.03.2022 17:32
The only suggestion I have is to uninstall/delete the Editor version you have (including any files in the appData folder- GIANTS Editor 64bit 9.0.2) and download/install a new copy of the editor from the download section of this forum.

Then carry out the method in my post of the 30.03.2022 20:06 making sure that all files are on your computer and not on any external drive i.e. Icloud/google Drive etc as I believe files may be saved to these locations but only after editing.

Bartson Fggse (bartson) 31.03.2022 18:00
When copying files from the game while creating a new mod from the game, the editor does not copy the weights files.
At the moment the console is showing errors, so we have at least some starting point.
The same errors as this apply to any texture weight:

Error: Failed to copy file 'C:/Program Files (x86)/Steam/steamapps/common/Farming Simulator 22/data/maps/mapFR/data/animalMud01_weight.png' to 'C:/Users/MyComputer/Documents/My FS 22 Mods/Mod_Map_FR/maps/mapFR/data/animalMud01_weight.png'.

Colin Smith (WrinkleysRule) 31.03.2022 18:25
Check that you are running Giants Editor as administrator and it has been excluded in your anti virus software.

Bartson Fggse (bartson) 31.03.2022 19:11
Yeah yeah that's the problem.

Thank you very much for help.

It was the antivirus program that made it impossible to overwrite these files and copy them from the game.

Thank you again
Regards BartsoNv3

(For all who have the same problem: try to disable anti-virus protection while writing textures)

Colin Smith (WrinkleysRule) 31.03.2022 20:59
Glad you have finally got it sorted, but the question now is, why was there no log errors previously.

Bartson Fggse (bartson) 31.03.2022 21:47
I have no idea, but it's important that it works

Note: Log in to post. Create a new account here.