Community Forum

XML problem

Forum Overview >> Farming Simulator 22

CategoryFarming Simulator 22
Created14.07.2022 02:17


Anonymus (MrSteveXD2) 14.07.2022 02:18
Error=XML_ERROR_MISMATCHED_ELEMENT ErrorID=14 (0xe) Line number=2: XMLElement name=vehicle


<?xml version="1.0" encoding="utf-8" standalone="no" ?>
<vehicle type="implement">
<annotation>Copyright (C) GIANTS Software GmbH, All Rights Reserved.</annotation>

Anonymus (MrSteveXD2) 14.07.2022 02:18
why?

Patton_M47 14.07.2022 02:51
what is it supposed to be? can I see the whole XML
but maybe add this
<vehicle type="implement" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../../../../shared/xml/schema/vehicle.xsd">

Anonymus (MrSteveXD2) 14.07.2022 02:53
<?xml version="1.0" encoding="utf-8" standalone="no" ?>
<vehicle type="implement">
<annotation>Copyright (C) GIANTS Software GmbH, All Rights Reserved.</annotation>

<storeData>
<name>Weightbumper FH</name>
<functions>
<function>$l10n_function_weight</function>
</functions>
<rotation>0</rotation>
<image>store_MMS_Weight_Bumper.dds</image>
<price>1700</price>
<lifetime>600</lifetime>
<brand>MMS_AGRILINE</brand>
<category>weights</category>
</storeData>

<base>
<typeDesc>$l10n_typeDesc_weight</typeDesc>
<filename>MMS_Weight_Bumper.i3d</filename>
<size width="2" length="2" />
<components>
<component centerOfMass="0 0 -0.2" solverIterationCount="10" mass="300" />
</components>
<schemaOverlay attacherJointPosition="0 0" name="IMPLEMENT" />
</base>

<attachable>
<inputAttacherJoints>
<inputAttacherJoint node="attacherJoint" jointType="implement" topReferenceNode="topReferenceNode" lowerRotLimitScale="0 0 0" upperRotationOffset="-1" lowerRotationOffset="0" needsLowering="false">
<distanceToGround lower="0.32" upper="0.75" />
</inputAttacherJoint>
</inputAttacherJoints>
</attachable>

<connectionHoses>
<hose inputAttacherJointIndices="1" type="electric" node="0>0|3|0" length="1.2" diameter="0.01" straighteningFactor="1.5">
<objectChange node="00>0|3|0|0" visibilityActive="false" visibilityInactive="true"/>
</hose>
</connectionHoses>

<attacherJoints>
<attacherJointConfigurations>
<attacherJointConfiguration name="Nein">
<objectChange node="0>2|2" visibilityActive="true" />
</attacherJointConfiguration>

<attacherJointConfiguration name="Ja" price="250">
<attacherJoint node="0>0|2|0|0" jointType="implement" >
<schema position="0.5 0" rotation="0" invertX="false" />
<topArm baseNode="0>0|2|0|1" filename="$data/shared/assets/upperLinks/walterscheid01.i3d" toggleVisibility="true" zScale="1"/>
</attacherJoint>
<objectChange node="0>2|3" visibilityActive="true" />
<objectChange node="0>0|2|0|1" visibilityActive="true" />
</attacherJointConfiguration>
</attacherJointConfigurations>
</attacherJoints>

<ai>
<agentAttachment width="1.4" height="1.0" length="0.8" lengthOffset="0.25"/>
</ai>

<lights>
<sharedLight linkNode="Licht_links" filename="$data/shared/assets/lights/lizard/sideMarker12.xml" />
<sharedLight linkNode="Licht_rechts" filename="$data/shared/assets/lights/lizard/sideMarker12.xml" />

<beaconLights>
<beaconLight node="0>1|3" filename="BeaconPack/FBK2.1_Frontblitz.xml" />
<beaconLight node="0>1|4" filename="BeaconPack/FBK2.1_Frontblitz.xml" />
</beaconLights>
</lights>

<designConfigurations>
<designConfiguration name="0Kg" params="300">
<objectChange node="Zustazgewichte1" visibilityActive="false" />
<objectChange node="Zustazgewichte2" visibilityActive="false" />
</designConfiguration>

<designConfiguration name="250Kg" params="550" price="300">
<objectChange node="Zustazgewichte1" visibilityActive="fasle" />
<objectChange node="Zustazgewichte2" visibilityActive="true" />
<objectChange node="main_component" massActive="550" massInactive="300"/>
</designConfiguration>

<designConfiguration name="250Kg 2" params="550" price="300">
<objectChange node="Zustazgewichte1" visibilityActive="true" />
<objectChange node="Zustazgewichte2" visibilityActive="false" />
<objectChange node="main_component" massActive="550" massInactive="300"/>
</designConfiguration>

<designConfiguration name="500Kg" params="800" price="700">
<objectChange node="Zustazgewichte1" visibilityActive="true" />
<objectChange node="Zustazgewichte2" visibilityActive="true" />
<objectChange node="main_component" massActive="800" massInactive="300"/>
</designConfiguration>
</designConfigurations>

<baseMaterial>
<material baseNode="0>1" name="Weight_mat">
<shaderParameter name="colorMat0" value="0.028 0.028 0.028" />
</material>

<material baseNode="0>2|3" name="Fanghaken_mat">
<shaderParameter name="colorMat0" value="0.028 0.028 0.028" />
</material>

<material baseNode="Zustazgewichte2" name="Gewichtvorne_mat" >
<shaderParameter name="colorMat1" value="0.06 0.331 0 0"/>
</material>

<material baseNode="Zustazgewichte1" name="Gewichthinten_mat">
<shaderParameter name="colorMat1" value="0.06 0.331 0 0"/>
</material>
</baseMaterial>

<baseMaterialConfigurations price="100" useDefaultColors="true" defaultColorIndex="6">
<material name="Weight_mat" shaderParameter="colorMat0" />
<material name="Fanghaken_mat" shaderParameter="colorMat0" />
</baseMaterialConfigurations>

<designMaterialConfigurations price="100" useDefaultColors="true" defaultColorIndex="0">
<designMaterialConfiguration name="$l10n_configuration_valueDefault" color="0.06 0.331 0.0 16" price="0"/>
<material name="Gewichtvorne_mat" shaderParameter="colorMat1" />
<material name="Gewichthinten_mat" shaderParameter="colorMat1" />
</designMaterialConfigurations>


<foliageBending>
<bendingNode minX="-0.7" maxX="0.7" minZ="-0.2" maxZ="0.75" yOffset="0" />
</foliageBending>

<wearable wearDuration="480" workMultiplier="5" fieldMultiplier="2"/>
<washable dirtDuration="90" washDuration="1" workMultiplier="2" fieldMultiplier="2"/>

<i3dMappings>
<i3dMapping id="main_component" node="0>" />
<i3dMapping id="attacherJoint" node="0>0|1" />
<i3dMapping id="topReferenceNode" node="0>0|0" />

<i3dMapping id="Zustazgewichte1" node="0>2|0" />
<i3dMapping id="Zustazgewichte2" node="0>2|1" />
<i3dMapping id="Blech" node="0>2|2" />
<i3dMapping id="Haken" node="0>2|3" />

<i3dMapping id="Licht_links" node="0>1|1" />
<i3dMapping id="Licht_rechts" node="0>1|2" />
</i3dMappings>
</vehicle>


Anonymus (MrSteveXD2) 14.07.2022 02:54
I had it and it was the same


Anonymus (MrSteveXD2) 14.07.2022 02:55
without other mods there is no this error

Patton_M47 14.07.2022 03:15
must be a mod conflict then try it with one mod to see what happens

William Rowe (Bonger76) 14.07.2022 03:45
I would look at the"<brand>MMS_AGRILINE</brand>" that is line 14, the MISMATCHED_ELEMENT error might be that you brands don't match
the one in your modDesc is different from your .xml this in your modeDesc something like this

<brands>
<brand name="MMS_AGRILINE" title="MMS Agriline" image="store_MMS_Weight_Bumper.dds"/>
</brands>

Not totaly shure but this were I would start

Anonymus (MrSteveXD2) 14.07.2022 11:32
Thank you for your help

I am having a problem with the second modem now. It is on Modhub but the tensioning belts do not work.

XML: https://pastebin.com/rDBkV2Fb

2022-07-14 11:29 Error: C:/Users/karol/Documents/My Games/FarmingSimulator2022/mods/FS22_Lizard_8_Bale_Trailer/xml/LizardbaleTrailer.xml. Error=XML_ERROR_MISMATCHED_ELEMENT ErrorID=14 (0xe) Line number=114: XMLElement name=tensionBelt.

Anonymus (MrSteveXD2) 14.07.2022 11:35
Fixed, zero bugs

But I have a problem
How to make the tension belts available when the autoload version is purchased?

XML https://pastebin.com/JQ1XFz7w


Note: Log in to post. Create a new account here.