Community Forum

TestRunner Questions

Forum Overview >> Farming Simulator 22

CategoryFarming Simulator 22
Created17.11.2023 23:06

Anthony Dinardo (Anthony07) 17.11.2023 23:06
How do I use the Test runner tool? I downloaded it and opened the application file, how do I get it to actually test my mod I want to submit to modhub?
Also I get an Error in the testrunner application:

Error: the following arguments are required: testData
Option a: drag and drop the directory of the unpacked mod onto the exe
Option b: run exe in cmd and provide the path of the unzipped mod directory as an argument

What does this mean? Any help will be greatly appreciated.

Colin Smith (WrinkleysRule) 19.11.2023 12:06
Option a: drag and drop the directory of the unpacked mod onto the exe

As it says drag and drop the unzipped map folder onto the TestRunner_public.exe file

Anthony Dinardo (Anthony07) 21.11.2023 03:36
When I drag and drop the unzipped mod molder onto the .exe file the program closes and doesn't seem to do anything.
Does the TestRunner_public.exe file have to be in a specific location on the PC to work properly? The program folder is currently on the desktop, not a designated folder.

Colin Smith (WrinkleysRule) 21.11.2023 16:39

Try moving your unzipped mod folder to your desktop and drag and drop from there , sometimes errors can occur if the mod is not on the same drive as the test runner.

Anthony Dinardo (Anthony07) 24.11.2023 03:51
Okay, that worked, my mod has been tested, I have fixed all the errors except one: I need to add MipMaps to an image. How do I do that?
Thank you for your help, Sorry I don't fully understand all this. (New modder here)

Colin Smith (WrinkleysRule) 24.11.2023 11:47
You can use the GIANTS Texture Tool v9.0.1 (Farming Simulator 22) (available in the downloads section of this forum) to create mipmaps and also convert textures to Giants texture format.
Full instructions for use are contained in the ReadMe file and in the template .gim
works by simply dragging and dropping image texture onto textureTool.exe.

Anthony Dinardo (Anthony07) 26.11.2023 03:33
I used the GIANTS Texture Tool v9.0.1 to create the proper dds. image format, then ran my Mod through TestRunner again and it passed with Zero errors or issues. I have submitted the mod to be tested on ModHub, hopefully it'll pass there too! Thank you for your help, you have been a great help with me getting my first mod onto Modhub :)

J.r. Strengers (Modgiant) 27.11.2023 01:57
I use the Epic games version of FS22 and there is a space between "Epic" and "Games" in the pathname.
fs22 testrunner doest not accept spaces in pathname so i can not use it.
Does anyone know how to solve this, i can not change the path.

I tried the drag and drop but the Testrunner can not find the path to the game.

Gordo Ismyname (gordoismyname) 14.05.2024 20:05
You can run the testTool.exe from the command line and pass in the game path as a parameter. Enclose the path with quotes and it will understand the space.

Andres Briz Corral (Funjetor) 21.05.2024 13:07
I have this error in the test runner. somebody could help me?

12:41:22 INFO TestRunner - Checking for update
12:41:22 INFO TestRunner - Loading predefined testSuite and output path
12:41:22 INFO Config - required TestRunner Config Version: 3
12:41:22 INFO Config - Config.test_data_path: C:/Users/Usuario/Desktop/mods modhub/FS22_anfora
12:41:22 INFO Config - no game installation directory given in testSuite, searching installation locations
12:41:22 ERROR root - 'NoneType' object has no attribute 'split'
Traceback (most recent call last):
File "", line 313, in main
File "", line 102, in __init__
File "utils\", line 133, in load_from_XML_file
File "utils\", line 169, in get_game_location
File "utils\", line 237, in get_game_location_from_registry_steam
File "utils\", line 83, in from_string
AttributeError: 'NoneType' object has no attribute 'split'

Note: Log in to post. Create a new account here.