Community Forum

Editor crashes on opening

Forum Overview >> Farming Simulator 22

CategoryFarming Simulator 22
Created04.01.2022 20:24

Justin Harris (harrjom) 04.01.2022 20:24
Editor crashes on opening. Able to use FS19 editor

Please help?

Peter Ammersinn (ammersinn) 04.01.2022 21:22
Please Post your Log.
You can find it at:
C:\Users\<User>\AppData\Local\GIANTS Editor 64bit 9.0.2

Justin Harris (harrjom) 05.01.2022 20:09
<window_layout x="0" y="0" width="1024" height="768" perspective=""/>
<undo stack_size="25"/>
<grid enable="false" subdivisions="24" spacing="1.000000"/>
<viewport nav_translation_scale="0.050000" nav_rotation_scale="0.004000" framed_rotate="false"/>
<file_recent files=""/>
<gizmo size="10.000000" frame_size="2.000000" frame_radius_scale="0.040000" nurbs_curve_picking_cv_radius="1"/>
<warning show_save_warning="true"/>
<info update_notification="true"/>
<logging file="true"/>
<i3d force_external_binary_files="false"/>
<toolbar name="Scripts 1"> </toolbar>
<toolbar name="Scripts 2"> </toolbar>
<toolbar name="Scripts 3"> </toolbar>
<toolbar name="Scripts 4"> </toolbar>
<toolbar name="Scripts 5"> </toolbar>

Ed Propsner (crotchfrog) 05.01.2022 23:03
Does it crash when opening the editor, or when opening a map or other file? Did you update your game installation path in the editor ?

Justin Harris (harrjom) 06.01.2022 08:24

I open the app and it crashes a second or so later without me being able to do anything. I have not updated the game installation path in the editor. How would I do that?

I noted that the FS19 editor did not crash and it had Persp under Scenegraph - I do not know if this is a factor

Many thanks for your help

Ed Propsner (crotchfrog) 06.01.2022 22:49
If you start the editor by itself, not by trying to open a map or mod, you will go to FILE>PREFERENCES>GENERAL and you will see a place for "game installation." However, if the editor is crashing just by starting it up this could be problematic. It's usually the case if you're trying to open a map or mod that it happens.

"Persp" is just the camera perspective, it should be there. Not a problem.

Justin Harris (harrjom) 07.01.2022 08:12

It just crashes without being able to click on anything.

Ed Propsner (crotchfrog) 07.01.2022 16:52
Have you tried to "run as administrator" to see if that makes any bit of difference? If it's crashing on its own, I'm not really sure. If you ran 8.2.2 I would think that 9.02 should run as well but I could be wrong. Bilbo is the expert with these things, perhaps when he comes along, he can get you pointed in the right direction.

Justin Harris (harrjom) 07.01.2022 20:11
Tried running as admin - no joy

There is an error now appearing - unable to execute file create process failed code 740 - The requested operation requires elevation

Hopefully Bilbo can sort as I have a six year old desperate for a lamborghin lol

Ed Propsner (crotchfrog) 07.01.2022 23:31
Lucky you, I have a 7 year old and could be less interested in FS, trust me, I tried ... LOL. Roblox is her thing,

Anywho, it sure does seem like a permissions issue to me. Do you have the editor saved in the same location as the old one? Check to see that you have write permissions. Looks like it's trying to create a file and getting shot down. Also try turning off antivirus if it's running.

Ed Propsner (crotchfrog) 07.01.2022 23:53
@Josh: I looked up the error and it's definitely a permissions/privileges issue. Windows has deemed you unworthy for some reason :) Google the error message and you'll find a plethora of possible ways to get past the error. If you throw enough mud at the wall ....

Note: Log in to post. Create a new account here.