Community Forum

Invalid compound index: 3>0

Forum Overview >> Scripting

Created14.07.2015 08:41

Lorenzos (lorenzoita) 14.07.2015 08:50
Hi, i'm making a cultivator. I made i3d, xml and modDesc.
The tool is bought at the shop but did not appear. In Log there is:

Invalid compound index: 3>0
Error: Running LUA method 'update'.
/Users/sgeiger/Documents/code/lsim2015/build/finalbin/dataS/scripts/Utils.lua(37) :

Lorenzos (lorenzoita) 14.07.2015 15:57
I managed to solve that problem, but the mod you do not see..

Emil Drefers (Unknown) 14.07.2015 16:39

are there any other error messages in the log?

Is the mod visible in the GIANTS Editor version 6.x ?


Lorenzos (lorenzoita) 14.07.2015 20:17
Yes, the mod is visible in the giants editor 6.0.3
In the log there is this warning:

Warning: Y-Translation of component 1 (node 0>) (siciltiller.i3d) should be 0
Warning: No clipdistance set to node 0> (siciltiller.i3d). Set default clipdistance (300)
Warning: No clipdistance set to node 1> (siciltiller.i3d). Set default clipdistance (300)
Warning: No ground reference nodes in /Users/lorenzosertori/Library/Application Support/FarmingSimulator2015/mods//Siciltiller/siciltiller.xml

Emil Drefers (Unknown) 15.07.2015 08:21

you should try to fix all warnings.

Setting the clip distance should be no problem, I guess.

To fix the y translation might be a bit more complicated.
In the end the pivot of the root node (0>) must be in the origin.
You can achieve this by either doing a re export from your 3d modeling program or by using the "freeze transformation" option in the GIANTS Editor (right click on an object in the scenegraph)


Lorenzos (lorenzoita) 15.07.2015 09:17

I re exported the model.
Now there are these Warning and this Error:

Warning: Y-Translation of component 1 (node 0>) (Siciltiller.i3d) Should be 0
Warning: No clipdistance September to node 0> (Siciltiller.i3d). Set default clipdistance (300)
Invalid compound index: 5> 15
Error: Running LUA method 'update'.
/Users/sgeiger/Documents/code/lsim2015/build/finalbin/dataS/scripts/Utils.lua(37): Attempt to index a nil value

Emil Drefers (Unknown) 15.07.2015 11:09

the error is still there.
Looks like you did not adjust the pivot of that object ( 0> ) in your 3D modeling program.

The other messages also mean what they say and should be fixed.


Lorenzos (lorenzoita) 15.07.2015 11:32
Yes, the pivot is at the center of the model.
In maya I did Modify->Center Pivot.

Emil Drefers (Unknown) 15.07.2015 11:58

seems like I did not explain it clear enough.

The pivot must not be in the "center" of the object/mesh

It has to be in the origin/center of the scene.
Just have a look at a default vehicle and I'm sure you will understand what this means.


Lorenzos (lorenzoita) 15.07.2015 12:41
I tried to put it in the middle "by hand" but I can not ..
There is a command to automatically center it?

Emil Drefers (Unknown) 15.07.2015 14:08

it should not be too hard to place the pivot in the center by hand.
But you are right it is way more easy and accurate by doing it "automatically".

As I use Maya to integrate vehicles I can only say something about that ..
and yes there is a function to do it ...
"Freeze Transformations" and "Reset Transformations" is what youw ould need to use.


Lorenzos (lorenzoita) 15.07.2015 14:45
I tried to do as you said but nothing has changed.

Emil Drefers (Unknown) 16.07.2015 08:42

to understand how this works you might create a simple cube in maya first and export it after you tried to change the position of its pivot.

Afterwards go ahead and try to edit your vehicle.


Note: Log in to post. Create a new account here.