Community Forum

Editor 9.0.2 won't open at all

Forum Overview >> Editor

Created14.02.2022 07:35

Josh Sylvester (gmngjoy) 14.02.2022 07:35
I rebooted my PC to install the latest windows update (, and after said update, the GE no longer is able to start up. The editor starts to load, goes into a (Not Responding) state, hangs and never opens.

Install version: GIANTS_Editor_9.0.2_win64

I have tried removing and reinstalling GE, I have tried starting both by attempting to open a valid .i3d file, as well as attempting to open editor.exe directly from the Program Files directory. Neither work.

Ed Propsner (crotchfrog) 14.02.2022 15:10
It might make zero difference, but have you tried "run as administrator?"

Josh Sylvester (gmngjoy) 14.02.2022 18:41
@Ed Propsner - thanks for the suggestion, but unfortunately that didn't help. Same error when running as administrator.

Matti Minkkinen (wopito) 15.02.2022 12:58

Mark Duxbury (Mark91us) 02.03.2022 10:20
Mines also not working. Started off all good and now it wont finish opening.. Ive just gone back to 9.0.1 and works fine

Ed Propsner (crotchfrog) 02.03.2022 16:50
@Mark: Are you running the most current version of the game? This is fairly common if you updated GE to it's most current version but not the game. A while back they pushed through an update mostly around shaders and GE 9.01 instantly had issues with it. Updating to 9.02 fixed this. With that being said, it would make sense that your game version is still pre-patch if reverting back to 9.01 fixes the issue. I'm not saying this IS the issue, but I had the same problem as well as many others and this mismatch in versions was the cause. Depending on how/where you purchased/downloaded the game, it may not have updated itself. It's worth a shot to check it out.

Jason Lacey (JaseLacey) 11.03.2022 11:53
Last night i was able to use 9.0.2 but this morning i just get it saying starting, try to import and it crashes

Ed Propsner (crotchfrog) 11.03.2022 12:31
It's possible that depending on what you were working on last night, the i3d might now contain an error keeping it form opening, especially if you were working with 3rd party mods/placeables or making direct edits to the i3d or dependent files. These types of issues don't become evident until you save your work and reload your project (when you closed GE and came back to it in the morning). What does the GE error log say?

Jason Lacey (JaseLacey) 11.03.2022 13:32
ok i have finally got it all to open however when i try and bring my blend to editor half of the model is missing

Note: Log in to post. Create a new account here.