Community Forum

Editor starts and then locks

Forum Overview >> Editor

Created31.08.2009 19:46

Bert Vanderbeke (Unknown) 31.08.2009 19:50

i have tried several things to make giants editor work.
but every time i start it, the editor opens and then it blocks.
so i see the all the buttons but i can't click on any of them
and only the close icon is ussable
if i click on that, i get an error screen that the program doesn't respond.
anyone know how to solve the problem?

thanks anyway!

Christian Ammann - GIANTS Software 31.08.2009 23:45
Hi Bert,

Can you post the editor log here.

Bert Vanderbeke (Unknown) 02.09.2009 14:19

could the problem be that i'm using windows vista?
because if i run on my other pc under windows XP i got the same problem.
where can i find the editor log? because if i find that one maybe i could see what the problem is. But can't find the log either...


Christian Ammann - GIANTS Software 02.09.2009 22:57
Path to the editor log on Vista: C:\Users\<username>\AppData\Local\GIANTS Editor 4.1.2\editor_log.txt

Bert Vanderbeke (Unknown) 16.09.2009 13:34
here my editor log:

Driver: NVIDIA PhysX Runtime
Version: 2.8.1
Driver: OpenAL Software
OpenGL Rendersystem
Card Vendor: ATI Technologies Inc.
Renderer: ASUS EAH4870 series
Version: 2.1.8304 Release
GL_NV_texture_compression_vtc not supported
GL_NV_vertex_program2_option not supported
GL_NV_vertex_program3 not supported
GL_NV_register_combiners2 not supported
max_texture_layers: 8
GL_NV_fragment_program_option not supported
GL_NV_fragment_program2 not supported
OpenGL initialization successful
GPU profile: Medium
View Distance Coeff: 1
Shadow Quality: 1
Skip Mipmaps: 1
Terrain LOD Distance Coeff: 1
Check for updates (

there isn't more info init

Matt Pochylko (Unknown) 27.10.2009 19:07
I have the same problem however i can use the buttons but they dont do anything. When I load a map it says editor.exe is not responding then shuts down. Here's my log:

Driver: NVIDIA PhysX Runtime
Version: 2.8.1
Driver: OpenAL Software
Check for updates (

I left it all night to see if it took a long time to load and in the morning it was still messed up. I did have it working two weeks ago when i edited a map, and now its not working.

Note: Log in to post. Create a new account here.