Community Forum

Giants Editor Not Loading anything

Forum Overview >> Editor

Created22.12.2014 22:05

Justin D. (Unknown) 22.12.2014 22:06
I have tried downloading multiple versions of GE. The program opens and will open the file, give me TONS of warning messages and tells me to check for updates. Any Solutions or Files I am missing?

Jack Kronemeyer (Unknown) 22.12.2014 23:34
I have GE 6.0.3 version, I am also having problems with loading maps I seems the only one that will load is the best starter map that I downloaded but it doesnt have any models I paid for the tutorial video for using it but as soon as I try to open the standard map on the video GE loads the map but as soon as it finishes loading it stops working with a pop up message then only option is to close the program

Lorenzos (lorenzoita) 24.12.2014 11:59
I too have the same problem.
For example, I open a file with GE but I see all gray.

Is there a solution?

Justin D. (Unknown) 26.12.2014 02:47
I haven't found one. I have been a FS2013 user since it came out. I love downloading mods and repainting / designing new textures. Now i would LIKE to be able to edit the mod even more to my liking. Right now I'm not feeling to confident I will be able to do that.

Lafage Xavier (Unknown) 31.12.2014 01:41
pour les carte fs 2013 prenez la version 5.03 et désinstallez la nouvelle version

Steven Young (Unknown) 31.12.2014 21:09
I to have the same problem it seems to load map01 but at the final loading have an error program stopped and I have no choice but to quit. I am gutted I to paid for the modding tutorial and was looking forward to making changes to my map by getting rid of buildings that have no use etc.
I have tried all versions of the editor but still the same and there seems to be no answers to this problem perhaps every one is on holiday ?
hope someone comes up with a resolve soon. But I Love this Game, kind of makes it worse realy......

Emil Drefers (Unknown) 06.01.2015 14:02

first of all you have to check which version of i3d file you are opening with which version of the GE.
With every new FS there are new formats (e.g. shader format).
But these formats are not compatible to each other.
Sp opening an 'ancient' mod with the latest GE does not work.

Grab the latest version of the GE and try to open the default map (Bjornholm) or default vehicles.
If that does not work please post an error message which is as detailed as possible.

One way how it could work is to open the GE first and the i3d file afterwards (when GE is already running).

In order to fix the (eventual?) problem in the GE we need as much information as possible to be able to reproduce the error.


P.S. Yes, we had holidays too :)

Joseph Metz (Unknown) 08.01.2015 02:00
im having the same problem, has anyone found a solution yet?

Joseph Metz (Unknown) 12.01.2015 22:44
CAPTURE_DEVICE_SPECIFIER ALC_STEREO_SOURCES ALC_MONO_SOURCES ALC_SYNC ALC_REFRESH ALC_FREQUENCY ALC_EXTENSIONS ALC_DEVICE_SPECIFIER ALC_DEFAULT_DEVICE_SPECIFIER ALC_ALL_ATTRIBUTES ALC_ATTRIBUTES_SIZE ALC_MINOR_VERSION ALC_MAJOR_VERSION ALC_TRUE ALC_FALSE ALC_INVALID No Error Invalid Device Invalid Context Invalid Enum Invalid Value Gü½¨F›ÃK—ê} *\rDirectSoundEnumerateA \dsound.dll DirectSoundCaptureEnumerateA Generic Software Generic Hardware Audigy X-Fi CT_OAL.DLL SetupDiEnumDeviceInterfaces SetupDiGetDeviceInterfaceDetailA SetupDiDestroyDeviceInfoList SetupDiGetClassDevsA setupapi.dll ADI_OAL.DLL OPENAL32.DLL *oal.dll \ OpenAL32.dll MMSYSTEM DirectSound DirectSound3D ™\ 8\ 8\ bad allocation e+000 À~PA €ÿÿGAIsProcessorFeaturePresent KERNEL32 

 !"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefghijklmnopqrstuvwxyz{|}~ = EncodePointer KERNEL32.DLL DecodePointer FlsFree FlsSetValue FlsGetValue FlsAlloc xTÐTCorExitProcess mscoree.dll runtime error
TLOSS error
SING error
DOMAIN error
An application has made an attempt to load the C runtime library incorrectly.
Please contact the application's support team for more information.
- Attempt to use MSIL code from this assembly during native code initialization
This indicates a bug in your application. It is most likely the result of calling an MSIL-compiled (/clr) function from a native constructor or from DllMain.
- not enough space for locale information
- Attempt to initialize the CRT more than once.
This indicates a bug in your application.
- CRT not initialized
- unable to initialize heap
- not enough space for lowio initialization
- not enough space for stdio initialization
- pure virtual function call
- not enough space for _onexit/atexit table
- unable to open console device
- unexpected heap error
- unexpected multithread lock error
- not enough space for thread data

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.
- not enough space for environment
- not enough space for arguments
- floating point not loaded
Microsoft Visual C++ Runtime Library

... <program name unknown> Runtime Error!


Josh Scott (redneckgamerz) 17.05.2015 22:22
i have the same problem but I cant even open GE. it says it cant load xml config file

Emil Drefers (Unknown) 18.05.2015 08:14

you can try to do a fresh installation:
- uninstall the GE
- delete the config folder: on win7 e.g. C:\Users\username\AppData\Local\GIANTS Editor 6.0.4
- install GE (newest version)

Please note:
- the GE does not run with all grahpics cards
- e.g. integrated GPUs (common in laptops) often don't work


Mike Jones (Unknown) 13.05.2016 23:05
Emil, you have just made my day. I had the same problem and its all fine now. Cheers

Jordan Perry (Unknown) 06.09.2016 18:27
Any solution to getting the grey screen when opening? I've deleted and downloaded the GE twice and still nothing. Thanks

Note: Log in to post. Create a new account here.