Community Forum

Mod Conversion Errors

Forum Overview >> Editor

Created12.02.2015 00:20

Shawn Santee (JDNHRAFrEaK) 12.02.2015 00:20
Hi there.

First off, if there's a topic somewheres else about mod conversion errors to 2015, please direct me to it. I've spent hours upon hours of researching.

Anyways, I have converted a few mods from 2013 to 2015 and worked fine other than a few shaders, textures, and other small things. I've picked converting up again and every Tractor I try to convert gives me the error "Error: Running LUA method 'update'.
D:/code/lsim2015/build/finalbin/dataS/scripts/AnimCurve.lua(193) : attempt to call global 'getFromKeyframes' (a nil value)" I have sat here at the computer for hours researching this error. I've read it could have something to do with the dynamic wheels in 15 and to add an empty transform group, then other replies say it has something to do with the .lua files.

After sitting here the past 2 days messing around with the XML Files, I've come to figure out that if I enter in "tractor" for vehicle type, the same error will come up. If I put in "tractor_cylindered" it says it's an unknown vehicle type when I know it's a type, and the "Running LUA" Error doesn't appear anymore.

Is there something I need to do to not have this error? Or should I just give up on the whole thing?

I've even changed out the wheels on the Mod I converted and still get the LUA Error.

Thanks in advance.

Emil Drefers (Unknown) 13.02.2015 14:27

yes "tractor_cylindered" is no more used.
The type "tractor" has the cylindered specialization integrated now.

Wheels can be placed directly in the mod, but they don't have to.

The error about "AnimCurve" might be due to a not correctly set up motor.
Please check the default tractors how they define the torqueCurve and other motor attributes ...
check every detail/attribute ;)


Note: Log in to post. Create a new account here.