Community Forum

Editor Not Opening

Forum Overview >> Editor

Created09.09.2015 04:18

Zach Edwards (Unknown) 09.09.2015 04:26
I am trying to run the latest version of Giants Editor on my Mac, using Wineskin Winery. Its an application that allows mac users to run windows programs, without installing a windows operating system on the computer through like Boot Camp. I got Giants Editor to open but I get the message "Cannot initate I3D, Shadow 3.0 Required. Download Latest Drivers Now." When I hit the OK button it just closes the program.

Yannik Zausig (Unknown) 09.09.2015 14:51

I had this problem a long time ago, when I tried to play FS13 on a laptop with onboard graphics. Can you post your PC specs, especially the graphiccard model, please. Or are Macs always built with the same technologies? Maybe your graphic card is too old. I'm sorry, if this can't help you. I have no experience with Macs.

Or, maybe a problem with Wineskin Winery...

I need some more information to help.

Best regards

Emil Drefers (Unknown) 11.09.2015 18:48

"virtual machines" like the afore mentioned program often have the problem of being unable to deliver enough support for rendering 3D graphics.
So, I'm sorry to say, but is just impossible to start the GIANTS editor this way.


Stanley Goscinski (Unknown) 27.10.2016 02:34
I installed Editor, and it installed fine. But when I start is I get and error can not create an OpenGl viewport. And When I hit ok It closes. Why am i getting this error?

Emil Drefers (Unknown) 27.10.2016 09:52

to me that sounds like a problem with your graphics card.
Your GPU might be outdated.


Mike Arnott (Unknown) 28.10.2016 21:34
on a 64 bit newer com with the same error open gl and whats a gpu? last editor ran fine on my coms

Note: Log in to post. Create a new account here.