Community Forum

Replacing Grass model for brush.

Forum Overview >> Editor

Created14.02.2016 18:43

Pawel Lesniak (Unknown) 14.02.2016 18:59
Hello i want to know how can i replace grass model for my map with my own model i dont want to change only a texture of grass but i want also make new shapes of it.

For example something like this

Kamion Matris (Unknown) 12.03.2016 19:26
Back in time, when Giants Editor saved all the mesh data in .i3d file, this was possible. You just had to open .i3d file with notepad and manually find and replace mesh data of grass foliage mesh.
Since GE saves meshes in .shapes file, this is no longer possible because .shapes file can not be opened or decrypted.

Shame on Giants, I know.. =\

Emil Drefers (Unknown) 14.03.2016 07:17

you can still edit the mesh which is used for the foliage(s).

1) to see the mesh which is used:
- open the map with a texteditor
- find the 'foliageSUbLayer' line which holds the definition for the foliage you want to change
- get the blockshapeIds ... e.g. blockShapeId=";8;9;10"
- create a new "Shape" entry at the very end of the Scenegraph ...
<Shape shapeId="8" name="myTestToFindBlockShape" translation="0 100 0" clipDistance="500" nodeId="22123" materialIds="211" receiveShadows="true"/>

- make sure that you adjust the values for "shapeId", "nodeId" and "maetrialIds"
- I hope you know what they mean and how to adjust them ...
- save the changes and open the map with the GIANTS Editor
- you will find a new object at the bottom of the scenegraph ... click it and hit 'f' to move the camera closer to it

- Voila, here is the shape which is used for the foliage ...

2) to adjust the mesh(es) of a foliage
- you 'only' have to 'reverse' the above steps (and add a shape before that)


Kamion Matris (Unknown) 27.03.2016 19:17
Step one worked fine.
But with step 2, there is a problem.
When I added new shape and copied its ID to grassFoliage blockShapeId (in my case 534) map wont load with GE.

Is there any other way replacing current foliage shape with new one?

Emil Drefers (Unknown) 29.03.2016 08:25


after you have imported new mesh into your map, I hardly believe that it will have the id 534.
There are probably plenty (thousands) of objects already in the map ...

So, I would guess that the shapeId is wrong ...
- import
- save
- open map with n++ and find the correct shapeId(s?!)


Kamion Matris (Unknown) 01.04.2016 19:40
No, the sapeId is 100% right.

Its funny what the real problem was. =)
Insted of importing new object, Ive (for testing purpose only) used Create>Primitives>Cube function in GE and thats what coused problems. I dont know why, but now I tried importing now objects and it works.

Thanks =)

Note: Log in to post. Create a new account here.