Community Forum

Error: Running LUA method 'loadMapFinished'

Forum Overview >> Editor

Created07.03.2016 18:57

Andrew Jones (Unknown) 07.03.2016 19:04
i am have a problem with a map. firstly i successfully made the changes and edits to a map, completed the process by zipping the archive and posting it to the server and it worked fine.

now how ever when i make any changes at all to the map i get the following error message in the log:

Error: Running LUA method 'loadMapFinished'.
D:/code/lsim2015/build/finalbin/dataS/scripts/Utils.lua(349) : bad argument #1 to 'find' (string expected, got nil)

i get this error simply by saving the i3d file, any idea on what may be causing the problem. the log file is relatively clean a few warnings about missing l10n entries but nothing else.


it is cause by an error in a mod that causes a program conflict. i stripped the mods folder bare and added back only the ones necessary for the map initially, then gradually introduced the essential tool, implements, placeables and vehicles.

add back a few at a time, that way you be able to spot more easily the problem mods. i tried all ways, and slow and steady won the day.

all the best


Andrew Jones (Unknown) 08.03.2016 00:58
no i haven't!

the giants log reads:

C:\Users\jones\Desktop\WIP\STATESv9_1\map\map01.i3d (45704.84 ms)
Scenefile 'C:/Users/jones/Desktop/WIP/STATESv9_1/map/map01.i3d' saved in 12882.358469 ms.
Deduplication - 537 blocks reduced to 530 blocks
Deduplication - 1010790 bytes reduced to 1004081 bytes
Deduplication - 4 blocks reduced to 4 blocks
Deduplication - 3108 bytes reduced to 3108 bytes

the game log reads:

Error: Running LUA method 'loadSharedI3DFileFinished'.
not enough memory
Application exit request forced.

GIANTS Engine Runtime 6.0.2 64bit (Build Date: Jan 14 2016)
Copyright (c) 2008-2015, GIANTS Software GmbH (, All Rights Reserved.
Copyright (c) 2003-2015, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: FarmingSimulator2015
Main System
CPU: Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
Memory: 16324 MB
OS: Windows NT 6.2 64-bit
Physics System
Version: 5.9.4
Thread(s): 2
Input System
Keyboard enabled
Mouse enabled
Gamepad/Joystick enabled
Force Feedback disabled
Sound System
Driver: OpenAL
Version: 1.1
Device: Generic Software
Max. sources: 256
Render System
Driver: OpenGL
Card Vendor: NVIDIA Corporation
Renderer: GeForce GTX 750 Ti/PCIe/SSE2
Version: 4.5.0 NVIDIA 361.91
Shader Version: 4.50 NVIDIA
max_texture_layers: 16
OpenGL initialization successful
Hardware Profile
Level: Medium (forced)
View Distance Factor: 1.000000
Shadow Quality: 1.000000
Skip Mipmaps: 1
LOD Distance Factor: 1.000000
Terrain LOD Distance Factor: 1.000000
Foliage View Distance Factor: 1.000000
Volume Mesh Tessellation Factor: 1.000000
Tyre Tracks Segments Factor: 1.000000
Farming Simulator 15
Version: 1.4.2RC1
Available Languages: en fr es it nl pt
Language: en

i made one set of changes, i added the value forage to the tip triggers value list for acceptable food types:

grass_windrow dryGrass_windrow silage forage_mixing

the addition was made to three troughs

and saved the map

the version before the change loads without error and runs on a dedicated multi player server with the same mods. yet by making that one set of changes i now have problems.

Emil Drefers (Unknown) 08.03.2016 07:26

well, I don't think that the adjustments to the tipTriggers are causing the error.

Probably there is something ...

Please check that the (texture) paths don't contain any special characters.

Depending on how much layers and buildings you have inserted it might really be the case that the map consumes too much memory.
What file size does the .zip archiv have? (normal or none compression)


Andrew Jones (Unknown) 08.03.2016 14:59
will investigate the texture paths later, but the data on the zip archive:

size 643 MB (675,147,047 bytes)

size on disk 643 MB (675,147,776 bytes)

normal folder:

size 1.14 GB (1,231,375,014 bytes)

size on disk 1.15 GB (1,236,078,592 bytes)

the entire mods directory

size 8.16 GB (8,762,239,411 bytes)

size on disk 8.16 GB (8,768,839,680 bytes)

hope this helps

Andrew Jones (Unknown) 08.03.2016 17:08
Emil, hi,

it appears to be a problem with the local development pc. the map loads and runs without error on a dedicated server.

GIANTS Engine Runtime 6.0.2 64bit (Build Date: Oct 13 2015)
Copyright (c) 2008-2015, GIANTS Software GmbH (, All Rights Reserved.
Copyright (c) 2003-2015, Christian Ammann and Stefan Geiger, All Rights Reserved.
Main System
CPU: Intel(R) Xeon(R) CPU E5-1650 v3 @ 3.50GHz
Memory: 130964 MB
OS: Windows NT 6.2 64-bit
Physics System
Version: 5.9.4
Thread(s): 2
Input System
Keyboard disabled
Mouse disabled
Gamepad/Joystick disabled
Force Feedback disabled
Sound System
Driver: NULL
Render System
Driver: NULL
NullConsoleDevice initialized
Hardware Profile
Level: Low (forced)
View Distance Factor: 0.750000
Shadow Quality: 0.000000
Skip Mipmaps: 1
LOD Distance Factor: 0.750000
Terrain LOD Distance Factor: 0.750000
Foliage View Distance Factor: 1.000000
Volume Mesh Tessellation Factor: 1.500000
Tyre Tracks Segments Factor: 0.500000
Farming Simulator 15
Version: 1.4.1RC2
Available Languages: en
Language: en
Game vehicle types loaded

there are some texture errors: width or height doesn't equal 2^n. what does this mean exactly? why are the files different types, a mix of png and dds? also they are different fixed ratio sizes, why is this? for example, map_dem is 1025x1025 and the weight files are 1024x1024.

what is giants preferred compression format for dds files and should minimaps be generated?

similarly, what format is the png in?

how does one go about calculating the memory requirements of a map? does it matter if the zip archive is highly compressed?

Emil Drefers (Unknown) 09.03.2016 08:08

jap, the following lines explain why the game can not run:

Render System
Driver: NULL
NullConsoleDevice initialized

It seems like there is no suitable graphics card in the PC.
You could try to update your drivers.
What graphics card do you have?
For gaming a dedicated gpu is highly recommended (onboard gpus have a bad performance).

Now about images ...

The width and height should equal 2^n for performance reasons.
so, valid values are: 2, 4, 8, 16, 32, 64, 128, 256, 512, 1024, 2048, ...

Normally .dds is preferred becaus eit can be laoded into the gou much faster.
But it has compression artefacts.
That' why we use png or our own format for some 'terrain detail layers'.

For a normal texture (e.g. on a building or a vehicle) you should use the .dds format (reall y highly recommended)


Andrew Jones (Unknown) 09.03.2016 13:07

those lines are from the dedicated multiplayer server on which the map runs fine and error free, it is the local machine that can not run the map without a memory error, the first set of stats is for the local pc

no problems with using dds, but which compression format?

again no problem with png, again which format, and should they be interlaced?

Emil Drefers (Unknown) 10.03.2016 08:03

please try if you can load and play the default maps - I bet you can.
Also try one or two ther mod maps - I bet you can.

I would say that > 300 MB for a map is a lot (maybe too much)
Especially if it has size of more than 1 GB without compression.

Also more than 8 GB of mods sounds very much to me.

I would start testing without any mod and just add your map.
Test if you get the same error ... maybe it's a mixture of mods which causes the problem.


Andrew Jones (Unknown) 14.03.2016 13:59
hi, Emil,

got it all sorted, it was a memory issue on the local machine not being able to open all the online mods and the map.

have set up a development folder with just a few utility mods and the mods necessary for the map and it loads ok, and with out error.

have learnt a lot in the process, thanks for your help

Note: Log in to post. Create a new account here.