Community Forum

Can't get any version of the editor to work for FS15 map

Forum Overview >> Editor

Created09.11.2016 19:39

Troy Christensen (hunter1390) 09.11.2016 19:43
Ive tried new ver 7.0.2 as well as all the way down to 5.0.3 I just get a message the editor doesn't respond and force closes right after start up can someone help

Roger Bauer (Buckslayer93) 09.11.2016 22:02
I have been having the same issue.

James Norred (Cajunwolf) 10.11.2016 02:17
Video card driver maybe? A little more detail about the problem specifics, and what you have already tried would help us a whole lot in possibly answering your question.

Troy Christensen (hunter1390) 10.11.2016 02:28
I have an Asus w/ i7 and nividia gforce gtx 960m card but I can't run any version of giants editor they all crash when I open any i3d file

James Norred (Cajunwolf) 10.11.2016 02:36
Interesting, but you don't have any problems in game, right? Sure sounds like a a driver issue to me, but a GTX 960 is a very common card, and many people would be having this same issue by now. Have you tried switching from Hardware to software rendering by chance? I notice FS games run on software open GL video, but you would be having trouble with the game too. Follow? It's got to be something specific. Does your log show anything?

Troy Christensen (hunter1390) 10.11.2016 03:34
GIANTS Engine Runtime 7.0.0 (13609:13610) 64bit (Build Date: Oct 25 2016)
Copyright (c) 2008-2016, GIANTS Software GmbH (, All Rights Reserved.
Copyright (c) 2003-2016, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 7.0.2
Main System
CPU: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
Memory: 16282 MB
OS: Windows NT 10.0 64-bit
Physics System
Version: 5.9.5
Thread(s): 2
Sound System
Driver: OpenAL Software
Render System
Driver: OpenGL
Card Vendor: NVIDIA Corporation
Renderer: GeForce GTX 960M/PCIe/SSE2
Version: 4.5.0 NVIDIA 369.09
Shader Version: 4.50 NVIDIA
Max. Texture Layers: 16
GL_AMD_depth_clamp_separate not supported
Started 4 threads for threadpool 'Render threadpool'
Hardware Profile
Level: High (forced)
View Distance Factor: 1.100000
Shadow Quality: 1.000000 Size: 2048 Filter-Size: 16
Shader Quality: 2
Skip Mipmaps: 0
LOD Distance Factor: 1.100000
Terrain LOD Distance Factor: 1.500000
Terrain Normal Mapping: Yes
Foliage View Distance Factor: 1.400000
Foliage Density: 0.500000
Volume Mesh Tessellation Factor: 0.850000
Tyre Tracks Segments Factor: 2.000000
Max. Number of Shadow Lights: 3
Max. Number of Lights: 512
Max. Number of Lights Per Cluster: 32
Check for updates (
this is all my log shows and I can play in game fine
how do I see what mode I'm in?

James Norred (Cajunwolf) 10.11.2016 11:00
Well all that tells ms that your system should handle it no problem, and especially if your playing the game on the same machine, and for these reasons I think we can rule out the hardware, and perhaps driver too. You running Windows 10 I see and your using openGL for render and sound, that's fine too. Any you've reinstalled the editor right? Just in case it foobared on install. Here's a thought, what's you display size, or what screen size are you trying to render? The reason I asking is that it is possible to have the game supporting a screen size that the editor might not, and it's worth a try. Make sure your monitor-LCD is set to a common size, and not something custom to a particular HD display. For instance I like my 1600x1200, but many prefer a wide screen aspect ratio, just make sure your running a common mode. In the mean time if something else comes to mind I'll post back.

Note: Log in to post. Create a new account here.